×

Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Registered User
    Join Date
    Jan 2010
    Posts
    3

    Unhappy Unable to visit Secure pages(https) using qwebview

    Hi guys,

    I really really need your help on the crippling problem I am facing:

    I am making a QT for Symbian app that needs to visit secure websites (https) sites as part of the program. I am using qwebview to display the web pages. While normal web pages turn out fine, the secure pages are not viewable (they just turn up as blank).

    After doing some research I found out that I need to call QNetworkReply::ignoreSslErrors() from the SLOT that is associated with the QNetworkAccessManager::sslErrors signal to ignore all SSL related errors(caused by visiting secure web pages)! I did that and the thing is that it works fine on my windows xp system but it gives the following error on my Vista based setup -
    QSslSocket: cannot call unresolved function SSLv3_client_method
    QSslSocket: cannot call unresolved function SSL_CTX_new
    QSslSocket: cannot call unresolved function SSL_library_init
    QSslSocket: cannot call unresolved function ERR_get_error
    QSslSocket: cannot call unresolved function ERR_error_string

    Ultimately I am looking at designing this application for Symbian based mobile phones and I want to make sure that secure web pages show up and work properly on all Symbian devices. Please let me know how I can overcome this or suggest an alternative of visiting secure pages!

    -Soham

  2. #2
    Registered User
    Join Date
    Jan 2010
    Posts
    7

    Re: Unable to visit Secure pages(https) using qwebview

    In emulator you can not browse secured pages because some dependency libs are not supported. so you try out in device itself but before that make sure that you have installed all the necessary libs in device.

  3. #3
    Registered User
    Join Date
    Jul 2010
    Posts
    6

    Re: Unable to visit Secure pages(https) using qwebview

    Hi,

    I had got the same error but that was before installing OpenSSl onto my WindowsVista. Mine is a Windows application. So, this error happens when we don't have a support to OpenSSL. You may have to give a SSl suport exteranlly (by installing OpenSSL) or internally ( by using QSslSocket libary) . I hope it would lead you in the right direction.

    Regards,

    Baluk

Similar Threads

  1. How to connect to a "Protected" Secure Element with JCOP tools?
    By herwijnen in forum Near Field Communication
    Replies: 1
    Last Post: 2009-06-29, 18:18
  2. Unable to install j2me apps in my Nokia N95 8GB (North America)
    By ngsubs in forum Mobile Java Networking & Messaging & Security
    Replies: 6
    Last Post: 2008-06-03, 17:37
  3. Reading and writing to the Secure Element (Nokia 6131)
    By wobbly101 in forum Near Field Communication
    Replies: 0
    Last Post: 2007-11-09, 13:43
  4. Replies: 3
    Last Post: 2005-10-12, 05:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×