×

Discussion Board

Results 1 to 2 of 2

Thread: Help Using VAS

  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    10

    Help Using VAS

    Hi,

    I am trying to use VAS to send/receive data. The DnLink and UpLink codec initialization is going perfect and the loopback example worked as well. I did some changes, but the problem is that EmptyBuffer is being called only once and then FillBuffer is called as long as the application is running. Code snippet:

    Code:
    void CVoIPTestEngine::EmptyBuffer(const CVoIPAudioUplinkStream& /*aSrc*/,
                                      CVoIPDataBuffer* aBuffer)
    {
        DEBPRN0(_L("CVoIPTestEngine::[0x%x]::EmptyBuffer :>"));
        aBuffer->GetPayloadPtr(iRecBufPtr);
        
        //GIVE DATA TO SEND
        iCallBack.giveDATA(iRecBufPtr);
    
        iVoIPUplink->BufferEmptied(aBuffer);
    }
    
    
    void CVoIPTestEngine::FillBuffer(const CVoIPAudioDownlinkStream& /*aSrc*/,
                                     CVoIPDataBuffer* aBuffer)
    {
    	
        DEBPRN0(_L("CVoIPTestEngine::[0x%x]::FillBuffer"));
        aBuffer->GetPayloadPtr(iPlayBufPtr);
    
        //GET RECEIVED DATA
        iCallBack.getDATA(iPlayBufPtr);
        iPlayBuf->SetPayloadPtr(iPlayBufPtr);
        iVoIPDnlink->BufferFilled(iPlayBuf);
    }
    I am using ILBC Codec and the Buffer size i get is 40. What am i doing wrong here. I previously used the DoLookBack function that is in the original example and things were working fine, but why is that it is not working this way? Also i thought that maybe iPlayBufPtr's length and maxsize are wrong or something, so i copied the structure of a "Filled" iRecBufPtr once and still it didnt work. What is the problem here?

  2. #2
    Registered User
    Join Date
    Sep 2009
    Posts
    10

    Re: Help Using VAS

    hmmm i tried to delete this thread, i copied this General Symbian C++ because somehow feel the VoIP discussion wont cater this.

Similar Threads

  1. G.711 noise with VAS
    By interface_johnson in forum Symbian Media (Closed)
    Replies: 0
    Last Post: 2009-10-29, 15:55
  2. VAS with siprtp example
    By islamfunny in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2009-06-22, 22:42
  3. Audio routing issue with VAS
    By raj_rr7 in forum VoIP
    Replies: 1
    Last Post: 2009-06-08, 06:57
  4. [Moved] Native ringtone support with VAS
    By ruchirvasavada in forum VoIP
    Replies: 1
    Last Post: 2008-12-01, 01:07
  5. VASP and VAS
    By ParitoshM in forum General Messaging
    Replies: 0
    Last Post: 2005-03-03, 12:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •