Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    8

    TRK on E90 shows error -21 "Failed to open debug trace port."

    Hi,

    I have an E90 and want to use on-device debugging with Carbide.c++ on it, but I am unable to establish a connection.

    The phone's version number as shown when typing *#0000# into the phone is:

    =====
    V 07.40.1.2
    03-10-2007
    RA-6
    Nokia E90 (206.03)
    =====

    I installed s60_3_1_app_trk_3_1_2.sisx on the phone. I have TRK started and switched to USB connection in the TRK settings. But when I try to connect it always shows me the following message (I tried restarting the phone and restarting the TRK, with and without USB cable connected, no change):

    =====
    Welcome to TRK for Symbian OS

    Status: Not connected

    Failed to open debug trace port.
    Error Code: -21
    =====

    I am running Windows XP and ADT 1.4 with all updates installed as a VMware guest system on a MacBook Pro running Mac OS X 10.6.2. I can access the E90's memory card via USB from the XP guest system, so basically the connection to the phone is working.

    I looked through the forum and googled for the error but did find nothing of help. Maybe you've got an answer or can point me in the right direction.

    Thanks in advance,
    Robert.

  2. #2
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: TRK on E90 shows error -21 "Failed to open debug trace port."

    Are you connected to the Nokia PC Suite? No Nokia PC Suite, no cookie - mass storage mode doesnt do it.
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  3. #3
    Registered User
    Join Date
    Aug 2009
    Posts
    8

    Re: TRK on E90 shows error -21 "Failed to open debug trace port."

    thank you! that helped. Just in case someone else gets stuck on a similar problem, this is roughly what i have done:

    I installed PC Suite on my Windows XP System.

    Then I had to switch to "PC Suite" mode on the phone, by going to the Menu -> Connectivity -> USB -> USB Mode

    After testing the connection with PC Suite, I deleted the TRK I had already installed on the phone and reinstalled it through Carbide / PC Suite.

    Then I launched the TRK on the phone, selected USB as connection and got the message (on the phone's display):

    =====
    Status: Connected
    Connection: USB
    Port: 1
    =====

    After that I went back to Carbide, selected "Debug" which brought up the "New Connection" dialog, clicked on the "initiate service testing" button and got the "Installed TRK is latest available version..." message in the dialog's window.

    That step was pretty much like explained on http://developer.symbian.org/wiki/in..._on_the_Device

    But I didn't get a "TRK SIS Selection dialog" (which is described as next step on the aforementioned page)

    Instead I had to select from Carbide's menu: Project -> Properties -> Carbide.c++ -> Build Configurations -> SIS Builder -> Add

    Then I selected the appropriate PKG file and closed the Properties-Dialog.

    Next I went to the menu: Run -> Debug Configurations... -> Symbian OS Application TRK -> MyProject Phone Debug (GCCE) -> there in the "Installation" tab I selected the SISX file that is generated by the PKG file (if you have never run a Build there will probably not be a SISX file and you'll have to enter the name manually).

    Additionally I checked the box "Install each launch even if installer file has not changed".

    Now it works! :-)

    Thanks again to tamhanna for the help!

    Bye,
    Robert.

  4. #4
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: TRK on E90 shows error -21 "Failed to open debug trace port."

    Hi,
    a pleasure!

    If it ever stops working, do another detect cycle in the connection window!
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

Similar Threads

  1. [moved] How to debug Console Exe from GUI application in TRK?
    By SymbianTH in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2009-10-22, 07:02
  2. Buggy AMR Audio Recording. Please Help!!
    By jhamby in forum Symbian
    Replies: 8
    Last Post: 2009-07-07, 10:34
  3. Replies: 4
    Last Post: 2009-07-07, 10:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×