×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Unhappy gsreamer-0.10-plugins-good+Phonon

    i write my application (Qt 4.6.2) for N900 using phonon to play wav
    effect, but application is mute and i have this message: "do
    you not seem to have package gsreamer-0.10-plugins-good
    installed"; this package is already installed newer version
    Also, i have found this thread https://garage.maemo.org/pipermail/q...ay/000514.html
    but i don't understand if this problem solved or not.

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: gsreamer-0.10-plugins-good+Phonon

    What is an output of the command:
    Code:
    dpkg -l gstreamer0.10-plugins-good

  3. #3
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by divanov View Post
    What is an output of the command:
    Code:
    dpkg -l gstreamer0.10-plugins-good
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-===================================================-================================-============================================
    ii gstreamer0.10-plugins-good 0.10.16-git276-0maemo4+0m5 GStreamer plugins from the "good" set

  4. #4
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: gsreamer-0.10-plugins-good+Phonon

    What about
    Code:
    dpkg -l "libqt4-*"
    on the device and inside your scratchbox.
    Also what is output of
    Code:
    ldd your_binary
    on the device?

  5. #5
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by divanov View Post
    What about
    Code:
    dpkg -l "libqt4-*"
    on the device and inside your scratchbox.
    Also what is output of
    Code:
    ldd your_binary
    on the device?
    on Scratchbox:

    [sbox-FREMANTLE_ARMEL: ~] > dpkg -l "libqt4-*"
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-=============================-=============================-==========================================================================
    ii libqt4-core 4.5.3~git20090723-0maemo6+0m5 Qt 4 core module
    ii libqt4-gui 4.5.3~git20090723-0maemo6+0m5 Qt 4 GUI module
    ii libqt4-maemo5-core 4.6.2~git20100212-0maemo1 Qt 4 core module
    ii libqt4-maemo5-dbus 4.6.2~git20100212-0maemo1 Qt 4 D-Bus module
    ii libqt4-maemo5-dev 4.6.2~git20100212-0maemo1 Qt 4 development files
    ii libqt4-maemo5-gui 4.6.2~git20100212-0maemo1 Qt 4 GUI module
    ii libqt4-maemo5-maemo5 4.6.2~git20100212-0maemo1 Qt 4 Maemo5 module
    ii libqt4-maemo5-multimedia 4.6.2~git20100212-0maemo1 Qt 4 Multimedia Libraries
    ii libqt4-maemo5-network 4.6.2~git20100212-0maemo1 Qt 4 network module
    ii libqt4-maemo5-opengl 4.6.2~git20100212-0maemo1 Qt 4 OpenGL module
    un libqt4-maemo5-opengl-dev <none> (no description available)
    ii libqt4-maemo5-phonon 4.6.2~git20100212-0maemo1 Qt 4 Phonon Libraries
    ii libqt4-maemo5-script 4.6.2~git20100212-0maemo1 Qt 4 script module
    ii libqt4-maemo5-sql 4.6.2~git20100212-0maemo1 Qt 4 SQL module
    un libqt4-maemo5-sql-sqlite <none> (no description available)
    ii libqt4-maemo5-svg 4.6.2~git20100212-0maemo1 Qt 4 SVG module
    ii libqt4-maemo5-test 4.6.2~git20100212-0maemo1 Qt 4 test module
    ii libqt4-maemo5-webkit 4.6.2~git20100212-0maemo1 Qt 4 WebKit module
    ii libqt4-maemo5-xml 4.6.2~git20100212-0maemo1 Qt 4 XML module
    ii libqt4-maemo5-xmlpatterns 4.6.2~git20100212-0maemo1 Qt 4 XML Patterns module


    on device:

    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name Version Description
    +++-===================================================-================================-============================================
    ii libqt4-core 4.5.3~git20090723-0maemo6+0m5 Qt 4 core module
    ii libqt4-dbus 4.5.3~git20090723-0maemo6+0m5 Qt 4 D-Bus module
    un libqt4-dev <none> (no description available)
    ii libqt4-gui 4.5.3~git20090723-0maemo6+0m5 Qt 4 GUI module
    ii libqt4-maemo5-core 4.6.2~git20100212-0maemo1 Qt 4 core module
    ii libqt4-maemo5-dbus 4.6.2~git20100212-0maemo1 Qt 4 D-Bus module
    ii libqt4-maemo5-gui 4.6.2~git20100212-0maemo1 Qt 4 GUI module
    ii libqt4-maemo5-maemo5 4.6.2~git20100212-0maemo1 Qt 4 Maemo5 module
    ii libqt4-maemo5-multimedia 4.6.2~git20100212-0maemo1 Qt 4 Multimedia Libraries
    ii libqt4-maemo5-network 4.6.2~git20100212-0maemo1 Qt 4 network module
    ii libqt4-maemo5-opengl 4.6.2~git20100212-0maemo1 Qt 4 OpenGL module
    ii libqt4-maemo5-phonon 4.6.2~git20100212-0maemo1 Qt 4 Phonon Libraries
    ii libqt4-maemo5-svg 4.6.2~git20100212-0maemo1 Qt 4 SVG module
    ii libqt4-maemo5-xml 4.6.2~git20100212-0maemo1 Qt 4 XML module
    ii libqt4-network 4.5.3~git20090723-0maemo6+0m5 Qt 4 network module
    ii libqt4-opengl 4.5.3~git20090723-0maemo6+0m5 Qt 4 OpenGL module
    ii libqt4-sql 4.5.3~git20090723-0maemo6+0m5 Qt 4 SQL module
    ii libqt4-sql-sqlite 4.5.3~git20090723-0maemo6+0m5 Qt 4 SQLite plugin
    ii libqt4-svg 4.5.3~git20090723-0maemo6+0m5 Qt 4 SVG module
    ii libqt4-xml 4.5.3~git20090723-0maemo6+0m5 Qt 4 XML module

    ldd /usr/bin/qmemory

    libQtMaemo5.so.4 => /opt/qt4-maemo5/lib/libQtMaemo5.so.4 (0x40001000)
    libphonon.so.4 => /opt/qt4-maemo5/lib/libphonon.so.4 (0x4001d000)
    libQtDBus.so.4 => /opt/qt4-maemo5/lib/libQtDBus.so.4 (0x4007a000)
    libQtXml.so.4 => /opt/qt4-maemo5/lib/libQtXml.so.4 (0x4011b000)
    libQtSvg.so.4 => /opt/qt4-maemo5/lib/libQtSvg.so.4 (0x40174000)
    libQtGui.so.4 => /opt/qt4-maemo5/lib/libQtGui.so.4 (0x401df000)
    libQtCore.so.4 => /opt/qt4-maemo5/lib/libQtCore.so.4 (0x40c9a000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x41168000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x41670000)
    libm.so.6 => /lib/libm.so.6 (0x41320000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x41150000)
    libc.so.6 => /lib/libc.so.6 (0x41028000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x412d8000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x411a8000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x41988000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x417c8000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x41750000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x41968000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x41500000)
    libz.so.1 => /usr/lib/libz.so.1 (0x413d0000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x41460000)
    librt.so.1 => /lib/librt.so.1 (0x41190000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0x41938000)
    libEGL.so => /usr/lib/libEGL.so (0x40f6b000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0x44e68000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0x44d28000)
    libdl.so.2 => /lib/libdl.so.2 (0x412c8000)
    /lib/ld-linux.so.3 (0x41000000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x414b8000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x414e0000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x414f0000)
    libIMGegl.so => /usr/lib/libIMGegl.so (0x40f76000)
    libsrv_um.so => /usr/lib/libsrv_um.so (0x40f8b000)

  6. #6
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: gsreamer-0.10-plugins-good+Phonon

    Everything looks correct. Did you try this demo for instance if it has the same problem:
    http://qt.gitorious.org/+qt-develope...s/qmediaplayer

  7. #7
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Unhappy Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by divanov View Post
    Everything looks correct. Did you try this demo for instance if it has the same problem:
    http://qt.gitorious.org/+qt-develope...s/qmediaplayer
    same problem....

  8. #8
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by niqt View Post
    same problem....
    qmediaplayer play aac file but don't play wav file

  9. #9
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Smile Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by niqt View Post
    same problem....
    resolved it.

  10. #10
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by niqt View Post
    resolved it.
    It would be beneficial to other people facing the same problem to know what was a root cause of it.

  11. #11
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Re: gsreamer-0.10-plugins-good+Phonon

    Quote Originally Posted by divanov View Post
    It would be beneficial to other people facing the same problem to know what was a root cause of it.
    The warning is shown, but file is played. My Wav file was corrupted then my player was mute, sorry.

Similar Threads

  1. Replies: 4
    Last Post: 2009-12-21, 10:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×