×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    13

    Unhappy Quick i need help

    Dear All;
    I am developing application that uses sensor APIs
    i used it successfully but my application will be for both 3rd and 5th
    in 3rd like 6620 my application doesn't completely work as the libraries of Sensor APIs are only for E66 , FP2 And 5th
    And i am reading many threads that suggest to create ECOM Plug-in but there is lot of problem i need to know :
    1- How To Build My ECOM Plugin itself that will contain both Sensor APIs used in 5th And in 5500????
    2- is there any way to catch system error -1 that appears on application opening on 5500(If using 5th API)????
    please i need avery quick help
    Thanks in advance;

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Quick i need help

    The easy way out is to build your application twice, with S60 3rd Edition MR SDK and with S60 5th Edition SDK, and then create one SIS file which installs the right binary on the right phone.

    Code:
    ; if 5.0 device
    if package(0x1028315F)
    "myapp_5_withsensor.exe" - "!:\sys\bin\myapp.exe"
    else
    "myapp_3_nosensor.exe" - "!:\sys\bin\myapp.exe"
    endif
    Alternatively you can learn about ECOM plug-ins and employ them to ensure that you can use either of the sensor APIs a device may support.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Sep 2009
    Posts
    13

    Thumbs up Re: Quick i need help

    hi ltomuta;
    first of all thanks for your quick reply....
    second your suggestion is simple and efficient
    third Is ECOM could help me in my questions????
    At last thank you again;

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Quick i need help

    ECOM is a plug-in framework and would help you in as much as providing you the means of having multiple implementations of your sensor engine and then dynamically deciding which one to use. Whether it is the best approach in this case or not its questionable. after all, on any given device you will only use one sensor API (if sensor at all supported) so any one plug-in at any given time. Which means that you don't really need the framework, instead you can have a statically linked DLL, a different version of which is then installed on device using similar logic as in my previous post. In other words you move the DLL selection logic from run-time (ECOM) to install time (standard DLL).
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Sep 2009
    Posts
    13

    Smile Re: Quick i need help

    Ok i See;
    Thanks for your valuable response

  6. #6
    Registered User
    Join Date
    Sep 2009
    Posts
    13

    Unhappy Re: Quick i need help

    hi ;
    i found another problem
    in N76 FP1 No Sensor APIs Supported so it gives system error -1 so ; how can i jum it
    thanks in advance;

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Quick i need help

    Don't install the version of the app which uses sensors on that device.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. [HELP] I lost the quick search button on my 5800 home screen
    By phuclorddn in forum General Development Questions
    Replies: 1
    Last Post: 2009-09-08, 16:17
  2. how to remove quick office log file from app manager in nokia n71?
    By imadsharieff in forum General Development Questions
    Replies: 0
    Last Post: 2007-10-31, 16:48
  3. quick fix for dku 5
    By anishthampy in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2004-11-12, 08:17
  4. Replies: 0
    Last Post: 2004-02-02, 17:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×