×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    52

    Nokia 6212 NFC SDK error

    Hey guys,

    I'm trying to install and configure the 6212 NFC SDK to be used with NetBeans 6.8.
    I installed the JDK and I have both the JRE 5 and 6 and when I try to add the
    Nokia 6212 NFC SDK as a platform in NetBeans I get an error that says that the JRE 5 isn't installed on my machine
    and thus the Nokia 6212 NFC SDK cannot be used. The error message is:
    "The SDK could not locate a Java Runtime Environment (JRE).
    You must install JRE 5 to run this SDK."
    I also have the Nokia S40 5th Edition FP1 installed on my machine and it works perfectly.
    I tried adding the JRE 5 bin path to the %PATH% environment variable and still no luck.
    I tried installing everything from scratch, and still no luck.
    I'm running Windows 7 x64 (I just reformatted my machine. Before the format I had the exact same OS
    and configuration and it worked perfectly with the 6212 SDK).

    Thanks!

  2. #2
    Registered User
    Join Date
    Jan 2010
    Posts
    29

    Re: Nokia 6212 NFC SDK error

    Quote Originally Posted by giaviv View Post
    Hey guys,

    I'm trying to install and configure the 6212 NFC SDK to be used with NetBeans 6.8.
    I installed the JDK and I have both the JRE 5 and 6 and when I try to add the
    Nokia 6212 NFC SDK as a platform in NetBeans I get an error that says that the JRE 5 isn't installed on my machine
    and thus the Nokia 6212 NFC SDK cannot be used. The error message is:
    "The SDK could not locate a Java Runtime Environment (JRE).
    You must install JRE 5 to run this SDK."
    I also have the Nokia S40 5th Edition FP1 installed on my machine and it works perfectly.
    I tried adding the JRE 5 bin path to the %PATH% environment variable and still no luck.
    I tried installing everything from scratch, and still no luck.
    I'm running Windows 7 x64 (I just reformatted my machine. Before the format I had the exact same OS
    and configuration and it worked perfectly with the 6212 SDK).

    Thanks!
    hi,

    I had the same problem under seven.
    I uninstalled everything and reinstalled in order, netbeans, Java ME SDK and 6212.
    Then I do "tools", "pluggins", "add platform".

    and I select to install for plugging work.
    I have all the javax.microedition.contactless, etc. ...

    tell me if you solved your problem

    best regards

  3. #3
    Registered User
    Join Date
    Mar 2010
    Posts
    2

    Re: Nokia 6212 NFC SDK error

    Hello friends! I'm working with netbeans 6.8 and sdk nokia 6212 and i'm trying to run my first project with the simulator of this sdk and I always get the same result:
    Starting emulator in execution mode

    Usage: emulator [-options] [Application]
    Xdescriptor: JAD file doesn't exist.
    where options include:
    -help Display this text
    -version Display version information about the emulator
    -classpath The class path for the VM
    -Xverbose[:allocation | gc | gcverbose | class | classverbose | verifier
    | stackmaps | bytecodes | methods | methodsverbose | frames
    | stackchunks | exceptions | events | threading | monitors
    | networking | all
    Enable verbose output
    -Xquery Print SDK option information and immediately exit
    -Xnew Forces a new emulator instance to be created, even if
    an existing emulator instance may be available for reuse.
    -Xuse:<phone number>
    Specifies a particular emulator instance to be reused, if that emulator
    instance exists and emulator instance reuse has been enabled.
    -Xkdpv:<level>
    Specifies the message tracing level (0 to 9) for the KVM debug proxy.
    -Xdebug Use a remote debugger
    -Xrunjdwp:[address=<address>,transport=dt_socket,server=<y>,suspend=<y>]
    Debugging options
    -Xdevice:<device name>
    Name of the device to be emulated
    -Xdescriptor:<jad file name>
    The JAD file to be executed
    -Xjam[:install=<jad or jar file url>]
    Java Application Manager and support
    for Over The Air provisioning (OTA)
    -Xheapsize:<size>
    (e.g. 65536 or 128k or 1M)
    Specifies the VM heapsize
    -Xhttp_proxy:<address>[:<port>]
    Defines the address and port number of the http proxy.
    -Xinbox:<file path>
    Specifies the path for the message inbox directory.
    -Xlanguage:<language name>
    Specifies the language for the SDK to operate in.
    -Xoutbox:<file path>
    Specifies the path for the message outbox directory.
    -Xontop If specified the SDK GUI window will always be on top of all
    other windows.
    -Xsecurity_domain:<domain name>
    Specifies a security domain for the MIDlet.
    Domain name can take the one of following values: Trusted, Untrusted, Maximum, Minimum.

    D:\Mis documentos\UCLM\3º (2)\Desarrollo de Componentes Software\ProyectoNFC\MobileApplication1\nbproject\build-impl.xml:889: Execution failed with error code 1.
    GENERACIÓN INCORRECTA (total time: 1 second)

    I have been searching for days and I have no solution. Does anybody know why of this result "Jad file doesn't exist" and the rest of the messagen??? how can I solve it?
    Excuse of my english. thanks.

  4. #4
    Registered User
    Join Date
    Sep 2010
    Posts
    1

    Re: Nokia 6212 NFC SDK error

    Dear All,

    I am newbie in Mobile and NFC developement....

    I am facing the same issue.
    Despite of re-installing 3 times the 6212 SDK, when I launch the emulator nothing appears (no error message)
    (Even by clicking on "Nokia Connectivity Framework Full/Lite", nothing runs also)

    In command prompt, I tried running the emulator with different arguments, but I can not do anything

    I have the JRE 1.6.0.21, running on XP SP2

    thanks in advance for your help

    Vinh14

  5. #5
    Registered User
    Join Date
    Feb 2009
    Location
    Hagenberg, Austria
    Posts
    121

    Re: Nokia 6212 NFC SDK error

    Hallo,

    have you tried to run the emulator shortcut in a command promt window? I.e. run "C:\Nokia\Devices\S40_Nokia_6212_NFC_SDK\bin\emulator.exe -Xnew" in a command promt.
    Are there any errors reported then?

    br,
    Michael

Similar Threads

  1. XMl Parser Implementation for Symbian
    By ittiam in forum Symbian
    Replies: 26
    Last Post: 2009-09-16, 05:26
  2. Browser monitoring
    By NevePankaj in forum Symbian
    Replies: 19
    Last Post: 2008-08-12, 10:06
  3. 3220 NFC Shell communication problem (Error Code: -6)
    By AllenHuang in forum Near Field Communication
    Replies: 1
    Last Post: 2007-09-17, 07:54
  4. problem with Code Warrior 5.2
    By mayankkedia in forum Symbian
    Replies: 4
    Last Post: 2006-06-22, 08:26
  5. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×