×

Discussion Board

Results 1 to 2 of 2

Thread: Sound latency

  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    9

    Question Sound latency

    Hi all,

    I'm new to J2ME. I wrote some application with buttons that make a sound when presed (like a typewrite sound - nice!).
    I used the Player with Manager.createPlayer. I've realized and prefetched the data. Yet, I experience a delay between pressing a button and hearing the sound. The sound is very short (25 ms, according to getDuration), and I also use three of those players for choosing the one that is not buisy playing a sound. But the latency still exists. I can quickly press four buttons one after the other, and then patiently hear the four following sounds in their own time...

    I'll appreciate your help in this matter.
    thanks

  2. #2
    Registered User
    Join Date
    Feb 2010
    Posts
    9

    Re: Sound latency

    I forgot to mention: I use nokia 5800

Similar Threads

  1. Sound Latency <100ms possible ?
    By nadeshiko in forum Symbian Media (Closed)
    Replies: 8
    Last Post: 2010-03-20, 00:38
  2. Problem with Sound class getState()
    By creepymo in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2005-06-20, 18:43
  3. MIDI Sound problem (J2ME / Series 60)
    By JPapke in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2004-10-29, 08:17
  4. Sound in Midp 2.0 stalls
    By astraton2001 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 4
    Last Post: 2004-03-25, 06:58
  5. sound bug (possibly) on 6610
    By alex_crowther in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2004-02-05, 11:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •