×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Dec 2009
    Posts
    8

    CVoIPUtilityFactory is source incompatible between S60v3_fp1 and v5

    The class CVoIPUtilityFactory is source incompatible between S60v3_fp1 (extension SDK) and S60v5

    In particular in voiputilityfactory.h in S60v3_fp1 contains the function
    IMPORT_C TInt CVoIPUtilityFactory::CreateBuffer(CVoIPDataBuffer*& aBuffer, const CVoIPDataBuffer::TVoIPBufferType aType);
    In S60v5 this is replaced with
    IMPORT_C TInt CVoIPUtilityFactory::CreateBuffer(CVoIPDataBuffer*& aBuffer, const CVoIPDataBuffer::TVoIPBufferType aType, const TVoIPCodecFormat aCodecFormat = EG711);

    Should I expect to be able to build a binary that works with both?

    Any recommendations?
    Last edited by muchadhesion; 2010-03-15 at 14:06.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: CVoIPUtilityFactory is source incompatible between S60v3_fp1 and v5

    is that part of the VAS ?, basically APIs in API plug-in are not coming with any compatibility promise, thus you need to do extensive testing to find out whether they work on devices you would want to use them in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×