×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Nov 2009
    Posts
    112

    Smile 'End button' doesn't close my app on Nokia 5800 (5th ed)

    Hello,

    Problem on the Nokia 5800 (5th edition):
    My application doesn't close when pressing the End button, it just displays the main screen for a fraction of a second, then goes back to the application.
    However it does go back to main menu when pressing the 'Menu button' and keep the app in the background, as expected.
    And of course, if you use the Exit option from the application, it also closes as expected.

    Tested on the Nokia E71 (3rd edition), this problem doesn't happen: it closes properly when pressing the End button.

    My application is made with Flash, then packaged in a sis file for 3rd edition (works on 5th ed. devices because of backward compatibility).

    It's my first time using Carbide C++ and packaging a sis file, your help would be much appreciated :-)

    Thanks a lot.
    Last edited by RomanAge; 2010-03-15 at 15:13. Reason: forgot to thank!

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: 'End button' doesn't close my app on Nokia 5800 (5th ed)

    it will be good to see your AppUi::HandleCommandL( TInt aCommand ) to check what is going wrong.

  3. #3
    Regular Contributor
    Join Date
    Nov 2009
    Posts
    112

    Re: 'End button' doesn't close my app on Nokia 5800 (5th ed)

    Thanks for your answer.
    I've finally found that the probably is probably Flash related (my app is Flash packaged into a sis file), the way it handles the red key event.

    I haven't tried yet, but here is a link to the problem addressed, and apparently solved:
    http://sajisoft.wordpress.com/2009/1...red-key-fixed/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •