×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Oct 2009
    Posts
    95

    error locating libQtWebKit library when migrated to Qt 4.6

    Hi there;

    in order to migrate to the new qt 4.6, i installed the libtqt4-maemo5-* libraries to the N900 phone using the instructions specified in the qt4 wiki (uninstall the previously installed qt 4.5.3 libs and installed the 4.6 one: http://wiki.maemo.org/Qt4_Hildon#Usi...6_in_Fremantle )

    I tried to run an application i made (written in Qt 4.5.0 and used to run perfectly on the phone with old Qt libs 4.5.3 with no problems at all), the aplicatgion was installed successfully but didn't start indicating that the " error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory"

    I made sure that I've installed all Qt libs needed by the application (libqt4-maemo5-core, libqt4-maemo5-gui, libqt4-maemo5-webkit)

    I don't know what went wrong. How can I fix this
    thanx in advance

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: error locating libQtWebKit library when migrated to Qt 4.6

    There is no promise for Qt 4.5.3 being binary compatible with Qt 4.6. You have to rebuild the binaries against Qt 4.6 to make it work properly.

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. Porting from N95 to N97 mini
    By crealab in forum Symbian
    Replies: 22
    Last Post: 2009-12-22, 14:56
  3. Error loading connection when obfuscation high?
    By ejakkk in forum Mobile Java General
    Replies: 8
    Last Post: 2009-06-26, 12:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×