×

Discussion Board

Results 1 to 13 of 13

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2010
    Posts
    49

    Thumbs down mplayer getting hang in n900

    I am using mplayer for playing video in my application in n900.My starting the mplayer process by using qprocess object.Sometimes video is playing well but some times it is getting paused.I need some other method to launch it.I am not getting why sometimes it is getting paused automatically.When i am pressing 'p' key 2 times then it is again get played.

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: mplayer getting hang in n900

    I don't think the problem is related to QProcess.

  3. #3
    Registered User
    Join Date
    Mar 2010
    Posts
    49

    Re: mplayer getting hang in n900

    ya.it is not due to qprocess.I think the comand i am using to trigger mplayer should be alter in this version of maemo.Can i know the comand to run the mplayer for slow cpu and dropped frame .It is getting paused some time due to may be not getting cpu resourse in my application due to heavy load or may be due to loss of frame in video.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: mplayer getting hang in n900

    Frankly speaking this is off-topic in this sub-forum. But mplayer gives you a lot of options you can use on slow systems http://tivo-mplayer.sourceforge.net/...layer-man.html You also would like to analyse console output of mplayer to learn more about the problem.

  5. #5
    Registered User
    Join Date
    Mar 2010
    Posts
    49

    Re: mplayer getting hang in n900

    i have tried all option with mplayer.I am using qprocess to launch it.Still sometime it is getting hang up (ie getting paused automatically).I did nt get the reason for this.Is this problem of qt or due to the video .How can I launch w/o using qprocess.Is there any other option to launch it.

  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: mplayer getting hang in n900

    Quote Originally Posted by babulamiet View Post
    Is this problem of qt or due to the video.
    mplayer is not using Qt for anything.

    Quote Originally Posted by babulamiet View Post
    How can I launch w/o using qprocess.Is there any other option to launch it.
    By typing mplayer in the XTerminal?

  7. #7
    Registered User
    Join Date
    Feb 2010
    Posts
    17

    Re: mplayer getting hang in n900

    Did you tried phonon-mplayer backend? It works in desktop Linux and windows. But I haven't tested it on Maemo yet.

Similar Threads

  1. Replies: 4
    Last Post: 2012-06-07, 09:09
  2. [moved] N900 Bluez Installation
    By hayderbme in forum General Development Questions
    Replies: 1
    Last Post: 2010-03-10, 18:05
  3. N900 not on selected mobile list N900 search problems
    By jimgilmour1 in forum [Closed] Publishing to Nokia Store
    Replies: 0
    Last Post: 2010-02-16, 09:30
  4. Replies: 2
    Last Post: 2008-04-18, 00:19
  5. Hang up the call in S60 V3
    By gpalvia in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2006-07-28, 10:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •