×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    430

    Feedback: Name clash in new Sensor API

    Hello,
    Am I the only one who thinks that http://qt.nokia.com/doc/qtmobility-1...r.html#connect is an unlucky name for a method in a subclass of QObject given that there is already a method called connect in QObject? The connect from QObject is close to a reserved word in the "programming language C++/Qt" offering the signal and slot feature. Having another connect is unlucky because it will not only confuse developers but also IDEs.

    I'd like to hear others opinions.

    Axel

  2. #2
    Registered User
    Join Date
    Mar 2010
    Location
    Australia
    Posts
    2

    Re: Feedback: Name clash in new Sensor API

    Thanks for this feedback. This particular item had already been brought up and the method was renamed to connectToBackend().

Similar Threads

  1. Feedback & Bug Reporting channel
    By aaumala in forum Series 40 & S60 Platform Feedback Archive
    Replies: 0
    Last Post: 2009-12-16, 10:56
  2. Feedback & Bug Reporting channel
    By aaumala in forum Tools and SDK Feedback (Closed)
    Replies: 0
    Last Post: 2009-12-16, 10:56
  3. Linker error on using --feedback (armlink) option
    By matuog in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2009-02-17, 10:15
  4. Suggestions to improve documentation for examples
    By heuven in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 0
    Last Post: 2008-12-06, 12:01
  5. Replies: 2
    Last Post: 2007-11-10, 13:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×