×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jul 2009
    Posts
    6

    QApplication construction fails

    Hi,

    I have a simple UI application that has a single QApplication object. When i try to start it twice i get this error showing on the screen:

    "Program Closed: Main CONE 28"

    The first instance of the UI still runs fine.

    When debugging, it shows that it fails at the point where it tries to construct the QApplication object (second time round).

    Is there a way to prevent this?

    Chi

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: QApplication construction fails

    For any GUI application using Qt, there is precisely one QApplication object, no matter whether the application has 0, 1, 2 or more windows at any given time.

Similar Threads

  1. CVideoPlayerUtility video streaming fails on 7610?
    By k4l4 in forum Symbian Networking & Messaging (Closed)
    Replies: 10
    Last Post: 2008-11-18, 16:18
  2. HELP: HTTPS connection always fails!
    By xiaomingzhou in forum Symbian Networking & Messaging (Closed)
    Replies: 11
    Last Post: 2008-04-07, 05:14
  3. UI construction fails
    By molst in forum Symbian
    Replies: 3
    Last Post: 2007-04-02, 11:07
  4. CTelephony construction fails (Nokia 6600)
    By hsagovac in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2004-10-25, 18:36
  5. Replies: 1
    Last Post: 2002-05-16, 19:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×