×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    10

    Unhappy Unable to Build Qt for Symbian

    Hi all,
    Im using Vista
    Its giving me the following errors while trying to build Qt for Symbian: ( I think its the problem with qmake- no idea what becasue all my environment and path variables are set!!) plz see last few lines of the build..

    C:\Qt\4.6.2>configure -platform win32-msvc -xplatform symbian-abld
    Which edition of Qt do you want to use ?
    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.
    o

    This is the Qt for Symbian Open Source Edition.

    You are licensed to use this software under the terms of
    the GNU Lesser General Public License (LGPL) version 2.1
    or the GNU General Public License (GPL) version 3.

    Type '3' to view the GNU General Public License version 3 (GPLv3).
    Type 'L' to view the Lesser GNU General Public License version 2.1 (LGPLv2.1).
    Type 'y' to accept this license offer.
    Type 'n' to decline this license offer.

    Do you accept the terms of the license?
    y
    Environment:
    INCLUDE=
    Unset
    LIB=
    Unset
    PATH=
    C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Tools\Command_Lin
    e_Tools
    C:\Perl\site\bin
    C:\Windows\system32
    C:\Windows
    C:\Windows\System32\Wbem
    C:\PROGRA~1\COMMON~1\ULEADS~1\MPEG
    C:\Program Files\ATI Technologies\ATI.ACE\Core-Static
    C:\Program Files\Common Files\Symbian\tools
    C:\Program Files\CSL Arm Toolchain\bin
    C:\Qt\4.6.2\bin
    C:\Perl\bin
    C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Tools\Command_Lin
    e_Tools
    \S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\gcc_mingw\bin
    \S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\tools
    \S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\gcc\bin
    C:\Program Files\Common Files\Symbian\Tools
    You are licensed to use this software under the terms of the GNU GPL version 3.Y
    ou are licensed to use this software under the terms of the Lesser GNU LGPL vers
    ion 2.1.
    See C:/Qt/4.6.23

    or C:/Qt/4.6.2L

    Configuration:
    minimal-config
    small-config
    medium-config
    large-config
    full-config
    system-sqlite
    build_all
    debug
    cross_compile
    Qt Configuration:
    release
    debug
    zlib
    png
    s60
    openssl
    ipv6
    script
    xmlpatterns
    phonon
    phonon-backend
    multimedia
    audio-backend
    webkit
    native-gestures
    svg
    minimal-config
    small-config
    medium-config
    large-config
    full-config

    QMAKESPEC...................symbian-abld (commandline)
    Architecture................symbian
    Maketool....................nmake
    Debug symbols...............yes
    Link Time Code Generation...no
    Accessibility support.......no
    STL support.................yes
    Exception support...........yes
    RTTI support................yes
    MMX support.................no
    3DNOW support...............no
    SSE support.................no
    SSE2 support................no
    IWMMXT support..............no
    OpenGL support..............no
    OpenVG support..............no
    OpenSSL support.............yes
    QtDBus support..............no
    QtXmlPatterns support.......yes
    Phonon support..............yes
    QtMultimedia support........yes
    WebKit support..............yes
    Declarative support.........no
    QtScript support............yes
    QtScriptTools support.......no
    Graphics System.............raster
    Qt3 compatibility...........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............plugin
    TIFF support............plugin
    JPEG support............plugin
    PNG support.............qt
    MNG support.............plugin
    FreeType support........no

    Styles:
    Windows.................yes
    Windows XP..............no
    Windows Vista...........no
    Plastique...............no
    Cleanlooks..............no
    Motif...................no
    CDE.....................no
    Windows CE..............no
    Windows Mobile..........no
    S60.....................yes

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................yes (system)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Qt\4.6.2
    Build is done in............C:\Qt\4.6.2
    Install prefix..............
    Headers installed to........
    Libraries installed to......
    Plugins installed to........\resource\qt\plugins
    Binaries installed to.......
    Docs installed to...........
    Data installed to...........
    Translations installed to...
    Examples installed to.......
    Demos installed to..........

    Support for S60.............yes
    Symbian DEF files enabled...yes
    Running syncqt...
    Creating qmake...
    execute: File or path is not found (nmake)
    execute: File or path is not found (nmake)
    Cleaning qmake failed, return code -1



    What could possibly be the problem?

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Unable to Build Qt for Symbian

    Quote Originally Posted by aparna.sr.14 View Post
    Hi all,
    Im using Vista
    Its giving me the following errors while trying to build Qt for Symbian: ( I think its the problem with qmake- no idea what becasue all my environment and path variables are set!!) plz see last few lines of the build..

    C:\Qt\4.6.2>configure -platform win32-msvc -xplatform symbian-abld
    Which edition of Qt do you want to use ?
    Type 'c' if you want to use the Commercial Edition.
    Type 'o' if you want to use the Open Source Edition.
    o

    This is the Qt for Symbian Open Source Edition.

    You are licensed to use this software under the terms of
    the GNU Lesser General Public License (LGPL) version 2.1
    or the GNU General Public License (GPL) version 3.

    Type '3' to view the GNU General Public License version 3 (GPLv3).
    Type 'L' to view the Lesser GNU General Public License version 2.1 (LGPLv2.1).
    Type 'y' to accept this license offer.
    Type 'n' to decline this license offer.

    Do you accept the terms of the license?
    y
    Environment:
    INCLUDE=
    Unset
    LIB=
    Unset
    PATH=
    C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Tools\Command_Lin
    e_Tools
    C:\Perl\site\bin
    C:\Windows\system32
    C:\Windows
    C:\Windows\System32\Wbem
    C:\PROGRA~1\COMMON~1\ULEADS~1\MPEG
    C:\Program Files\ATI Technologies\ATI.ACE\Core-Static
    C:\Program Files\Common Files\Symbian\tools
    C:\Program Files\CSL Arm Toolchain\bin
    C:\Qt\4.6.2\bin
    C:\Perl\bin
    C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Tools\Command_Lin
    e_Tools
    \S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\gcc_mingw\bin
    \S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\tools
    \S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\gcc\bin
    C:\Program Files\Common Files\Symbian\Tools
    You are licensed to use this software under the terms of the GNU GPL version 3.Y
    ou are licensed to use this software under the terms of the Lesser GNU LGPL vers
    ion 2.1.
    See C:/Qt/4.6.23

    or C:/Qt/4.6.2L

    Configuration:
    minimal-config
    small-config
    medium-config
    large-config
    full-config
    system-sqlite
    build_all
    debug
    cross_compile
    Qt Configuration:
    release
    debug
    zlib
    png
    s60
    openssl
    ipv6
    script
    xmlpatterns
    phonon
    phonon-backend
    multimedia
    audio-backend
    webkit
    native-gestures
    svg
    minimal-config
    small-config
    medium-config
    large-config
    full-config

    QMAKESPEC...................symbian-abld (commandline)
    Architecture................symbian
    Maketool....................nmake
    Debug symbols...............yes
    Link Time Code Generation...no
    Accessibility support.......no
    STL support.................yes
    Exception support...........yes
    RTTI support................yes
    MMX support.................no
    3DNOW support...............no
    SSE support.................no
    SSE2 support................no
    IWMMXT support..............no
    OpenGL support..............no
    OpenVG support..............no
    OpenSSL support.............yes
    QtDBus support..............no
    QtXmlPatterns support.......yes
    Phonon support..............yes
    QtMultimedia support........yes
    WebKit support..............yes
    Declarative support.........no
    QtScript support............yes
    QtScriptTools support.......no
    Graphics System.............raster
    Qt3 compatibility...........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............plugin
    TIFF support............plugin
    JPEG support............plugin
    PNG support.............qt
    MNG support.............plugin
    FreeType support........no

    Styles:
    Windows.................yes
    Windows XP..............no
    Windows Vista...........no
    Plastique...............no
    Cleanlooks..............no
    Motif...................no
    CDE.....................no
    Windows CE..............no
    Windows Mobile..........no
    S60.....................yes

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................yes (system)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Qt\4.6.2
    Build is done in............C:\Qt\4.6.2
    Install prefix..............
    Headers installed to........
    Libraries installed to......
    Plugins installed to........\resource\qt\plugins
    Binaries installed to.......
    Docs installed to...........
    Data installed to...........
    Translations installed to...
    Examples installed to.......
    Demos installed to..........

    Support for S60.............yes
    Symbian DEF files enabled...yes
    Running syncqt...
    Creating qmake...
    execute: File or path is not found (nmake)
    execute: File or path is not found (nmake)
    Cleaning qmake failed, return code -1



    What could possibly be the problem?


    Thid Qt for the embedded version created problem in so many problems and it requires so much time to launch I prefer you to download this from QT:]

    qt-symbian-opensource-4.6.0-beta1

    Best regards,

Similar Threads

  1. Unable to build while launched the emulator in Debug mode - app is closed when build
    By amitkankani in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2007-05-23, 08:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×