Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2009

    make sis error Qt 4.7


    I've been following the instructions for installing Qt 4.7 onto Symbian from source: http://doc.qt.nokia.com/4.7-snapshot...l-symbian.html

    However I use mingw32-make instead of make. Qt built successfully for both 'debug-winscw' and 'release-armv5'. I am only interested in 'release-armv5' though, since I want to install Qt onto a device.

    The problem arises when I follow the instructions to build the Qt sis files using the target 'sis'. Since I'm using mingw32-make, the command I run is:
    mingw32-make sis QT_SIS_OPTIONS=-i QT_SIS_CERTIFICATE=MyCertificate.der QT_SIS_KEY=MyKey.pem
    However I recieve the following error:

    make -f Makefile ok_sis MAKEFILES=.make.cache
    make[1]: Entering directory `T:/qt-src-4.7.0/src/s60installs'
    createpackage.bat -i Qt_template.pkg RELEASE-ARMV5  SEMCTestInstall.der 
    Processing qt_release-armv5.pkg...
     Error : Cannot find file : t:/epoc32/release/armv5/urel/phonon_mmf.dll
    qt_release-armv5.pkg(32) : error: file I/O fault.
    file I/O fault, cannot open qt_unsigned.sis.
    SIS creation failed!
    make[1]: Leaving directory `T:/qt-src-4.7.0/src/s60installs'
    I traced the flow of control:

    Step 1) mingw32-make sis
    Step 2) Makefile sis target
    Step 3) createpackage.bat
    Step 4) createpackage.pl
    createpackage.pl seems to have a problem when it attempts to create a sis file from the Qt_template.pkg file. I tested this by attempting to create the sis file manually using the following command.

    makesis Qt_template.pkg
    I received the following error:

    Processing Qt_template.pkg...
     Error : Cannot find file : t:/epoc32/release/$(PLATFORM)/$(TARGET)/phonon_mmf.dll
    Qt_template.pkg(32) : error: file I/O fault.
    Both errors report the phonon_mmf.dll file cannot be found. Has anyone had this problem or have any suggestions to btter track down the problem?

    Update on this problem

    I tried commenting out the phonon entries in Qt_template.pkg, however the error just moved to the next binary it couldn't find. So I guess it's not phonon specific, but some problem with paths, perhaps $PLATFORM and $TARGET are incorrect, leading to lines like the following causing an error:

    "t:/epoc32/release/$(PLATFORM)/$(TARGET)/phonon_mmf.dll"    - "c:\sys\bin\phonon_mmf.dll"
    Last edited by anothertest; 2010-04-09 at 15:31.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Tampere, Finland

    Re: make sis error Qt 4.7

    Very likely $(PLATFORM) = armv5 and $(TARGET) = urel are correct (assuming you have the RVCT compiler), but also very likely the files you're looking for do not exist at the time you attempt to pack them into a SIS file. Or do they?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Jul 2009

    Re: make sis error Qt 4.7

    phonon_mmf.dll and phonon_mmf.lib do exist, but only in \epoc32\release\winscw\udeb

    I cannot find them in any other release sub directories. I looked in the Makefile for qt 4.7 source and am going to try building qt 4.7 using the command 'abld build armv5 urel' and see if that places the binaries under \epoc32\release\armv5\urel.

    Update on this problem

    There were some directories missing in epoc32\include, various mmp files used include paths which couldn't be found. Here is some sample build output:

    make -s  -C \qt-src-4.7.0\src\s60main -f "MAKEFILE_0X2001E61F.MK" TO_ROOT=..\..\.. EPOCBLD=\EPOC32\BUILD\MAKEFILE_0X2001E61F\WINSCW TO_BLDINF=..\..\..\qt-src-4.7.0 PLATFORM=WINSCW MAKMAKE
    perl -S makmake.pl  -D \qt-src-4.7.0\src\s60main\S60MAIN_0X2001E61F WINSCW   
    WARNING: \qt-src-4.7.0\src\s60main\S60MAIN_0X2001E61F.MMP(62) : SYSTEMINCLUDE path "\epoc32\include\stdapis\stlport\" not found
    The part in bold refers to the following code in in S60MAIN_0X2001E61F.MMP

    SYSTEMINCLUDE		/epoc32/include/stdapis/stlport
    For some reason I'm missing the stlport directory. Could this be the cause of the problem? However, they are only warnings, not errors.
    Last edited by anothertest; 2010-04-12 at 13:05.

Similar Threads

  1. S60 5th Edtion SDK faild compile
    By granan in forum Symbian Tools & SDKs
    Replies: 11
    Last Post: 2009-11-03, 16:19
  2. Replies: 12
    Last Post: 2009-10-26, 10:29
  3. How to make a sis file
    By saimram in forum Symbian
    Replies: 5
    Last Post: 2008-01-29, 10:14
  4. Failed to update file .RSC
    By Jayakumar in forum Symbian Tools & SDKs
    Replies: 32
    Last Post: 2007-10-26, 10:33
  5. SIS building !!!???
    By noussaENSI in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-03-23, 16:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts