×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    5

    Widget does not connect to internet

    Hi!

    I'm developing a WRT widget using WRTKit.
    When testing in my computer everything works fine. But when I install the widget on my Nokia E63 it doesn't connect to the internet.

    Example:

    I have a menu where I select an option. on the selectionCHanged event i do a ajax request for get data to build a new menu. On my e63 when I select the option, I'm not promped asking if the widget can connect to the internet and the second menu appears empty.

    Am I forgeting something? in my info.plist I granted network access to the widget.

    Thanks

  2. #2
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,100

    Re: Widget does not connect to internet

    Hello woozpt,

    I was thinking if you could share your code partially either here on the discussion board,
    or if you could send it to me via e-mail? I could have a look at it.

    Because it would be easier for me to check what your code actually does. The fact that you
    you are not prompted for access, you earlier mentioned that in the plist file you granted
    the access to the widget?

    Anyhow, it might just be that the connection actually takes place, but the AJAX call does
    not either return correctly or result is not handled correctly, I have not seen the error
    handling in your code either.

    To be able to assist you further, could you possibly send me your widget, or at least the
    info.plist content and the part where your AJAX transaction takes place and the return
    data is handled?

    My corporate e-mail is: marko.lumivuori@nokia.com


    Best Regards,
    [FONT="Comic Sans MS"][COLOR="Blue"][/COLOR][I]Marko Lumivuori
    Technical Support
    +358 40 8019330
    [email]marko.lumivuori@nokia.com[/email][/I][/FONT]

  3. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    5

    Re: Widget does not connect to internet

    Thank you! I will send you an email.

  4. #4
    Registered User
    Join Date
    Apr 2010
    Posts
    5

    Re: Widget does not connect to internet

    Anyone?

    Here is my Info.plist

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Nokia//DTD PLIST 1.0//EN" "http://www.nokia.com/DTDs/plist-1.0.dtd">
    <plist version="1.0">
        <dict>
            <key>DisplayName</key>
            <string>SHOWTIME!</string>
            <key>Identifier</key>
            <string>its.showtime2</string>
            <key>Version</key>
            <string>1.0</string>
            <key>MainHTML</key>
            <string>index.html</string>
            <key>AllowNetworkAccess</key>
            <true/>
            <key>MiniViewEnabled</key>
    	<false/>
        </dict>
    </plist>

  5. #5
    Regular Contributor
    Join Date
    Mar 2006
    Posts
    83

    Re: Widget does not connect to internet

    Plist doesn't point to the problem. Have you tried testing your app at RDA?
    Best regards,
    Dusan

  6. #6
    Registered User
    Join Date
    Apr 2010
    Posts
    5

    Re: Widget does not connect to internet

    I tried in RDA on E52 and works fine.
    On e63 has the exact same behavior of my device: does not prompt for connection / does not connect.

  7. #7
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Widget does not connect to internet

    Are you sure that selectionChanged event is ever fired on E63?
    You could place some debug message to that handler and if it is reached, then make sure that the configured network access point is accessible.

    E52 uses more recent browser than E63 hence there might be some differences in handling the events.

    Br,
    Ilkka

Similar Threads

  1. Can´t connect to internet w/ nokia e62
    By Josmanms in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2007-07-23, 05:15
  2. how do i set up the emulator to connect to the internet
    By cheemathew in forum Symbian Networking & Messaging (Closed)
    Replies: 7
    Last Post: 2005-04-25, 07:30
  3. how do i set up the 9200 emulator to connect to the internet
    By vinayakak in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-03-10, 10:50
  4. 3410 emulator connect to internet??
    By friedelcraft in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2004-07-16, 20:58
  5. Help us: configure 7650 emulator to connect it to the internet?
    By gekecn in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2002-10-10, 02:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×