×

Discussion Board

Page 2 of 2 FirstFirst 12
Results 16 to 21 of 21
  1. #16
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    Re: Intaller problem at 5530

    Ciao,

    I use only the launcher method since all the others have some quirks to deal with.

    About the icon, I do not think there is a way to deal with in the task manager since the launcher app passes the swf to the FL player and then quits.
    I do not think is a big deal, but it's up to you to make that decision.

    Alessandro

  2. #17
    Regular Contributor
    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    111

    Re: Intaller problem at 5530

    Ciao Biskero,

    How can you make your apps Symbian Signed, if the your app doens't show the correct icon at task list?

    best regards,
    Atila Correia
    SCJP, SCWCD, SCJA and MCP C#
    Game Developer and 3D Modeller
    www.atilacorreia.com
    www.linkedin.com/in/atilacorreia

  3. #18
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    Re: Intaller problem at 5530

    Ciao,

    you pass the tests since it's a Flash Lite application and they know it's how it works.
    Remember when you sing your application, you are signing the launcher executable not the swf.
    Also an icon is showing not missing. It's your in the menu and the Flash Lite player in the task menu.

    It's like you are setting an icon for a video but when you press that icon the real player on the phone will launch.

    In fact when you do express sign you need to select Flash as application.

    Alessandro

  4. #19
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,562

    Re: Intaller problem at 5530

    Your other post which had the same issue that you are discussing here http://discussion.forum.nokia.com/fo...d.php?t=200561

  5. #20
    Regular Contributor
    Join Date
    Mar 2008
    Location
    Brazil
    Posts
    111

    Re: Intaller problem at 5530

    Ciao Biskero,

    very enlightening your explanation.

    Thanks a lot.
    Atila Correia
    SCJP, SCWCD, SCJA and MCP C#
    Game Developer and 3D Modeller
    www.atilacorreia.com
    www.linkedin.com/in/atilacorreia

  6. #21
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    Re: Intaller problem at 5530

    Ciao,

    just to add to the previous post, here is how Symbian define content:

    “Symbian Signed defines Passive Content (PC) as any SIS file that does not contain any executable (active) components.”

    which means that the swf is not the active component, it's the Flash Lite player.
    The Flash Lite swf content is the Passive Content.

    In our case the launcher app is the Active Content which requires Symbian Signed (Express Sign).

    Alessandro

Similar Threads

  1. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  2. SyncML link problem
    By samuel_ in forum Symbian
    Replies: 4
    Last Post: 2009-03-27, 08:02
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×