×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2010
    Posts
    2

    N900 Maemo 5 HildonPortraitFlags

    I'm building an application with my starting point the maemo_examples, so it is Hildon. I'm using the N900 in an application that will always be in portrait mode.

    I'm using hildon_gtk_window_set_portrait_flags() to set HILDON_PORTRAIT_MODE_REQUEST. I'm testing in Xephyr on a Debian platform. The display paints nicely in portrait mode, just as I want. The problem is that the buttons don't work properly in that the touch screen has not been rotated. I.e., in a screen with a 3 x 3 button filling the top of the screen, if I press the upper right when viewed in portrait it activates the upper left. Of course the upper right in portrait would be the upper left in landscape.

    Does anyone know if there is some other setting I need to make to get the touch screen to work properly, or is this a bug in Hildon when rotated?

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: N900 Maemo 5 HildonPortraitFlags

    Did you try with HILDON_PORTRAIT_MODE_SUPPORT | HILDON_PORTRAIT_MODE_REQUEST as a flag?

Similar Threads

  1. Urgent reinstalling software to Maemo in N900
    By viorel.albu in forum General Development Questions
    Replies: 1
    Last Post: 2010-04-15, 21:42
  2. RTcom
    By LAS_VEGAS in forum Nokia N9
    Replies: 8
    Last Post: 2010-01-20, 15:12
  3. N900 / Maemo
    By proberts in forum [Closed] Publishing to Nokia Store
    Replies: 6
    Last Post: 2009-10-06, 23:21
  4. N900 MAEMO and Midp...
    By sblantipodi in forum Mobile Java General
    Replies: 50
    Last Post: 2009-10-05, 18:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×