×

Discussion Board

Results 1 to 15 of 17

Hybrid View

  1. #1
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Unhappy Problems while installation of J2 Apps

    Dear Sir/Ma'am

    I am posting this with very heavy heart. There are lot's of issues that I am facing during the installation of my Application.

    My J2ME Application is signed by Verisign omitting the jarsign step, and is installed on S60 and S40 Nokia mobiles.

    It uses pushRegisty (both dynamic(checked once) and static) for SMS, HttpConnection, FileConnection, PIM, RMS, XML handling sending or
    receiving of SMS. The mode of installation may be any :OTA, bluetooth, datacable. I have compiled the application using NetBeans 6.71 and wtk 2.5.

    Problems I face are:

    1. After so many installations in 5700 Nokia Ex. Music, there times come that on every second day of installation the application stops opening.
    Then sometimes it deletes the existing record store to install over the previous installation.

    2. In s40 series (any mobile: 3200, 5200, 7200) when the application is installed, it installs successfully first time, next time I have to upgrade
    the app version, then it will install. Problem is that whenever there is an error or say the app is running and the battery is removed, the
    Application Manager stops seeing that the application had registered with the same port number. It says there is a conflict, some different
    application uses the same port, while this is not a case. The other applications that were registered seem to be unregistered also.


    3. Sometimes installation of the application using the OTA fails when the unauthorized exception comes, while the certificate is installed already. I
    have known that if you don't clear the cache then the problem occurs.

    4. I display the version of the application in an alert using the JAD entry. Sometimes the application is installed and displays some previous version.

    Please help, the noose is around my neck.

    I will be highly obliged.

    Regards
    Abhinav Saxena
    Last edited by abhsax1978@hotmail.com; 2010-05-05 at 08:58.

  2. #2
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: Problems while installation of J2 Apps

    Quote Originally Posted by abhsax1978@hotmail.com View Post
    Problems I face are:

    1. After so many installations in 5700 Nokia Ex. Music, there times come that on every second day of installation the application stops opening.

    Then sometimes it deletes the existing record store to install over the previous installation.
    When application start opening, was any alert/exception/message drawn/thrown by the device?

    When you are reinstalling the application the device must ask that "Saved existing data" kind of alert to the user, and if you pressed no..then the already saved data will be lost for sure.Are you doing this?


    Quote Originally Posted by abhsax1978@hotmail.com View Post
    2. In s40 series (any mobile: 3200, 5200, 7200) when the application is installed, it installs successfully first time, next time I have to upgrade the app version, then it will install.

    Problem is that whenever there is an error or say the app is running and the battery is removed, the
    Application Manager stops seeing that the application had registered with the same port number. It says there is a conflict, some different application uses the same port, while this is not a case. The other applications that were registered seem to be unregistered also.
    Yeah that's correct and must be asked if and only if you are trying to install the same application which is already there on the device.That's not an issue.

    First bold line,I guess you are not managing the Port registration/de-registration in a proper manner. You read the Push Registry documentation on the web and then you will come to know that how to move exactly.


    Second bold lines, how are you sure that the port was free?

    Quote Originally Posted by abhsax1978@hotmail.com View Post
    I display the version of the application in an alert using the JAD entry. Sometimes the application is installed and displays some previous version.
    What do you mean?
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  3. #3
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Unhappy Re: Problems while installation of J2 Apps

    Sir,

    I have installed this application using the same port several times. Now the many runs of this application and the receipts of SMS (notification messages) were successful, and then I did the above said battery test. Only after that the conflict error comes. Sometimes invalid application error also comes when I removed the same app and installed the app with the same version using the new PC suite, by first removing the earlier.

    Therefore I can say that the port is not taken by some other application.

    Regards,

    Abhinav Saxena.

  4. #4
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Re: Problems while installation of J2 Apps

    Quote Originally Posted by abhsax1978@hotmail.com View Post
    Sir,

    I have installed this application using the same port several times. Now the many runs of this application and the receipts of SMS (notification messages) were successful, and then I did the above said battery test. Only after that the conflict error comes. Sometimes invalid application error also comes when I removed the same app and installed the app with the same version using the new PC suite, by first removing the earlier.

    Therefore I can say that the port is not taken by some other application.

    Regards,

    Abhinav Saxena.
    I think I have to restart each issue separately. But do continue on with the s40 issue first. That is the top priority.

    Regards
    Abhinav Saxena

  5. #5
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Re: Problems while installation of J2 Apps

    My application crashes: While push registered application is running, if the battery is taken out, or any other error comes, when the application is restarted, it fails to recognize that the port was registered by the same application but it says that the port was registered by some other non existent MIDlet. Whether you register dynamically or statically. This happens in Nokia-S40 series phones.

    I think the question and the solution would be, whether you should shut down the device so that the Push Registry remains intact, as the Application also gets shut down before you change the batteries?

    Or un-register the application push on exit, not getting the benefit of this feature.

  6. #6
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Re: Problems while installation of J2 Apps

    Quote Originally Posted by abhsax1978@hotmail.com View Post
    I display the version of the application in an alert using the JAD entry. Sometimes the application is installed and displays some previous version.
    I am using application.getProperties() to get the version from JAD which I am displaying in the alert. My clients reported that during the installation of the application the version was say 4.0 but when the launched the about alert, they got 3.0 there. This looks like the other matter I have already mentioned here: instead of overriding the application the fresh installation occurs and the db is removed (though not always). I never got the confirmation since ages like "do you want to keep your existing data?".. This I have seen myself.

    Regards
    Abhinav

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,087

    Re: Problems while installation of J2 Apps

    Update the firmware of your test device, on which you are facing such issues.

    thanks,
    ~Amitabh

  8. #8
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Re: Problems while installation of J2 Apps

    Quote Originally Posted by im2amit View Post
    Update the firmware of your test device, on which you are facing such issues.

    thanks,
    ~Amitabh
    Please help me find the solution for the s40 PushRegistry battery restart problem also.

    Please remind me if the firmware update is the only solution you have.

    Regards

  9. #9
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,087

    Re: Problems while installation of J2 Apps

    You can try soft/hard format for your device also.

    thanks,
    ~Amitabh

  10. #10
    Registered User
    Join Date
    Jun 2008
    Posts
    30

    Re: Problems while installation of J2 Apps

    Quote Originally Posted by im2amit View Post
    You can try soft/hard format for your device also.

    thanks,
    ~Amitabh
    Sir,
    Our client is going to be really unhappy about this, but thanks for the suggestions.

    Now facing another issue in 5700. The application has stopped opening after several runs. The log shows that the available heap space (Runtime.getRuntime().freeMemory()) is as low as 18 Kb in this device last run. When the app did not run then the log was also not made.

    I don't have the idea what is causing the problems. To reduce the application size I had obfuscated, compressed, ommitted the debug info, and converted Images used in the application from 8bpp to 4bpp (bytes per pixel).
    Regards

  11. #11
    Registered User
    Join Date
    Jun 2010
    Posts
    4

    Re: Problems while installation of J2 Apps

    The same issue is found to be existing in Nokia 7310 Supernova. The push registry fails completely and there is no way to rectify the issue found. I have performed soft reset as well as OS upgrade using PC suite. Series 60 Phones were not found to have the issue.

Similar Threads

  1. Problems in Nokia Software Updater installation
    By argelo in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 2
    Last Post: 2008-12-21, 16:06
  2. Problems in Nokia Software Updater installation
    By argelo in forum General Development Questions
    Replies: 1
    Last Post: 2008-12-21, 11:58
  3. PC Suite Connectivity API installation problems
    By user_bea in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2006-01-19, 14:48
  4. Problems in NDS JME beta 0.3 installation
    By mturu70 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2002-05-25, 10:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×