×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Question Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    Hi all,

    I read that Java Runtime 2.1 supports JSR 177 APDU.
    I have 3 questions.

    Does the jsr 177 APDU is include in the Beta version,
    Does a midlet that want access to this API must be signed with particular cerificate,
    When the release version is planed.


    Thanks very much,
    Adrien

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    Hello Adrien,


    Does the jsr 177 APDU is include in the Beta version
    According to JRT 2.1 release notes on Forum Nokia Wiki, the Beta release includes the support for the API: http://wiki.forum.nokia.com/index.ph..._Release_notes

    Does a midlet that want access to this API must be signed with particular cerificate
    The security settings for JSR-177 (SATSA-APDU package) are defined on Forum Nokia Java Developer's Library: http://library.forum.nokia.com/topic...C3070E70C.html

    When the release version is planed.
    For reference, check out the public roadmap available on Forum.Nokia.com: http://www.forum.nokia.com/piazza/bl...ctober2009.pdf

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    So with this API I sign my midlet correctly I will be able to send APDU to the SIM Card on the phone, isn't it?

  4. #4
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    It says that the card must have an ACF File. If the ACF file doesn't exists what append? All the APDU are forwarded to the applet or it will be rejected?

  5. #5
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    It's sure that with a Thawte certificate my application will be able to access all the APIs (jsr 177-APDU for example) on a Nokia N97 or N97 mini phone?

    Also is it Code Signing Certificate for Sun Java™ that I 've to purchase to sign my Midlet to get access to the APis?


    Thanks,
    Adrien

  6. #6
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    I find more information about the ACF File. I learn that the ACF File is needed only if a PKCS#15 application is located in the card. If not, all permission will granted. Is it true?



    Thanks,
    Adrien

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,073

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    Also is it Code Signing Certificate for Sun Java™ that I 've to purchase to sign my Midlet to get access to the APis?
    3rd party certificate is good for your task, ref to http://library.forum.nokia.com/
    Impelmentation Notes - JSR 177 - Symbian platform Runtime envirnoment notes - Securtiy settings - Table of Access rights of access domain


    It is recommended that you locate the ACF files in the pkcs#15 or WIM application and use a relative path in the ACIF. If an absolute path is used in the ACIF, the ACF must be readable on all logical channels; otherwise, the terminal might not be able to access the ACF.
    thanks,
    ~Amitabh

  8. #8
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    I agree with your second quote but if the PCKS#15 application is not present in the sim card, what append?

  9. #9
    Regular Contributor
    Join Date
    May 2009
    Posts
    52

    Re: Java Runtime 2.1 and JSR 177 (SATSA-APDU)

    Hi,

    The JSR 177 implementation do not mention that the PCKS#15 application is mandatory or optional.

    So my question is does a PCKS#15 app located in the card is needed to use the JSR 177 in the phone?



    Thanks, Adrien

Similar Threads

  1. real SSCD support for JSR 177 on Nokia devices
    By 4midp in forum Mobile Service Architecture (Closed)
    Replies: 1
    Last Post: 2009-09-18, 16:19
  2. Problems in Installing jar and jad file on to Nokia 6300
    By kris_sagar in forum Mobile Java Networking & Messaging & Security
    Replies: 27
    Last Post: 2009-05-22, 08:01
  3. problem with jsr 177 (satsa)
    By mhssamadani in forum Mobile Java General
    Replies: 6
    Last Post: 2009-04-09, 09:48
  4. SATSA ( JSR 177) support in N75
    By charithh in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2007-10-04, 01:24
  5. JSR #177 (SATSA) Problems with the installation
    By MCrill in forum Mobile Java General
    Replies: 0
    Last Post: 2004-09-24, 10:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •