×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    1

    Question J2ME S40 appliction not Playing MIDI Note.

    Hello,

    I have a very simple custom (but properly signed) J2ME application which is designed to play MIDI notes. The .jad/.jar application runs as designed on a J2ME simulator. But when loaded and executeed on (specifically) a Nokia 5130 cell phone, the generated music does play, but only at one pitch (e.g. the there is no melody, the music is monotone).

    I am new to everything cell phone related. Any guidance about what is different about the S40 implementation, that would cause the issue would be greatly appreciated. And would be grateful for direction on how to troubleshoot this issuem.

    Samsen

  2. #2
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,098

    Re: J2ME S40 appliction not Playing MIDI Note.

    Hello samsen,

    For that device model, both MIDI Monophonic, MIDI Polyphonic should be true.

    You could try to install and run the MIDlet on another hw device, just for comparison.

    When talking about MIDi, that brings us to polyphonic tones and merely like RTTTL and iMelody
    are main monophonic ringtone formats.

    Would be also nice to have a glimpse into your code, if you could possibly post or e-mail?

    Best Regards,
    [FONT="Comic Sans MS"][COLOR="Blue"][/COLOR][I]Marko Lumivuori
    Technical Support
    +358 40 8019330
    [email]marko.lumivuori@nokia.com[/email][/I][/FONT]

  3. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    5

    Re: J2ME S40 appliction not Playing MIDI Note.

    I think this is the same problem I am having, and possibly the same issue people have been having since 2003?

    My issue along with example source is in this thread:
    http://discussion.forum.nokia.com/fo...418#post726418

    Did you find a solution?
    I've been looking at this for over a month now!

    Thanks...

Similar Threads

  1. GoogleIt
    By deepika.mangla in forum Symbian
    Replies: 5
    Last Post: 2011-05-28, 11:04
  2. s40 Midi Support
    By und3f in forum Mobile Java Media (Graphics & Sounds)
    Replies: 7
    Last Post: 2010-05-29, 23:03
  3. Error loading connection when obfuscation high?
    By ejakkk in forum Mobile Java General
    Replies: 8
    Last Post: 2009-06-26, 12:54
  4. another Null pointer exception
    By kvchen1985 in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2004-06-28, 15:33
  5. Replies: 1
    Last Post: 2003-06-21, 16:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×