×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    2

    "Could not start application: General OS-related error" - When deploying on device

    Hi

    I couldn't see this error mentioned elsewhere, but apologies if I have missed it somewhere.

    I've just got a 5230 and installed the QT Beta on my Vista Windows set up. I get this error trying to run the Animated Tiles example on the device (Simulator worked ok)

    At the deploying stage I get this output:

    Executable file: 113879 2010-05-07T09:24:09 C:\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\animatedtiles.exe
    Package: 112584 2010-05-07T23:38:34 C:\NokiaQtSDK\Examples\4.6\animation\animatedtiles\animatedtiles.sis
    Deploying application to 'Nokia 5230 USB (COM15)'...
    Copying install file...
    Installing application...
    Starting application...
    Could not start application: General OS-related error
    Finished.

    ON the 5230 I have the the TRK App running with:

    Status: Connected
    Connection: USB
    Port: 1

    Cheers
    Stu

  2. #2
    Registered User
    Join Date
    May 2010
    Posts
    2

    Re: "Could not start application: General OS-related error" - When deploying on devic

    Hi,

    Apologies, I was following the procedure in "Getting Started with the Nokia Qt SDK" and somehow missed the key step of installing the qt_installer.sis to the device!
    It is all working fine now
    Thanks.
    Stu

  3. #3
    Registered User
    Join Date
    Sep 2007
    Posts
    16

    Re: "Could not start application: General OS-related error" - When deploying on devic

    Me too same problem. Any body has a solution ?

    Quote Originally Posted by stu62 View Post
    Hi

    I couldn't see this error mentioned elsewhere, but apologies if I have missed it somewhere.

    I've just got a 5230 and installed the QT Beta on my Vista Windows set up. I get this error trying to run the Animated Tiles example on the device (Simulator worked ok)

    At the deploying stage I get this output:

    Executable file: 113879 2010-05-07T09:24:09 C:\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\animatedtiles.exe
    Package: 112584 2010-05-07T23:38:34 C:\NokiaQtSDK\Examples\4.6\animation\animatedtiles\animatedtiles.sis
    Deploying application to 'Nokia 5230 USB (COM15)'...
    Copying install file...
    Installing application...
    Starting application...
    Could not start application: General OS-related error
    Finished.

    ON the 5230 I have the the TRK App running with:

    Status: Connected
    Connection: USB
    Port: 1

    Cheers
    Stu

  4. #4
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: "Could not start application: General OS-related error" - When deploying on devic

    Quote Originally Posted by fala70 View Post
    Me too same problem. Any body has a solution ?
    Did you install qt_installer.sis on the device?

  5. #5
    Registered User
    Join Date
    Sep 2007
    Posts
    16

    Re: "Could not start application: General OS-related error" - When deploying on devic

    Yes. If I install the app from ovi, and I run from dev, the app work good. The problem is when I try to deploy and run the app from QT Creator look log. Teh same app on N95 and SDK 3rd, I can deploy and run from QT Creator.

    Creating C:\test\test_gcce_urel.sisx ...
    Executable file: 913652 2010-05-31T10:51:15 C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\release\gcce\urel\test.exe
    C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\tools\makesis.exe test_gcce_urel.pkg
    C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\tools\signsis.exe test_gcce_urel.sis test_gcce_urel.sisx C:\Qt\4.6.2\src\s60installs\selfsigned.cer C:\Qt\4.6.2\src\s60installs\selfsigned.key
    Package: 777732 2010-05-31T10:51:18 C:\test\test\test_gcce_urel.sisx
    Deploying application to 'Nokia N97 USB (COM7)'...
    Copying install file...
    Could not create file C:\Data\test_gcce_urel.sisx on device: General OS-related error
    Finished.


    Quote Originally Posted by divanov View Post
    Did you install qt_installer.sis on the device?
    Last edited by fala70; 2010-05-31 at 10:49.

  6. #6
    Registered User
    Join Date
    Sep 2007
    Posts
    16

    Re: "Could not start application: General OS-related error" - When deploying on devic

    Sorry deploy work, is the start the problem, follow correct output:

    Creating C:\test\test_gcce_urel.sisx ...
    Executable file: 913652 2010-05-31T10:51:15 C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\release\gcce\urel\test.exe
    C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\tools\makesis.exe test_gcce_urel.pkg
    C:\S60\devices\Nokia_N97_SDK_v1.0\epoc32\tools\signsis.exe test_gcce_urel.sis test_gcce_urel.sisx C:\Qt\4.6.2\src\s60installs\selfsigned.cer C:\Qt\4.6.2\src\s60installs\selfsigned.key
    Package: 777732 2010-05-31T11:46:01 C:\test\test_gcce_urel.sisx
    Deploying application to 'Nokia N97 USB (COM7)'...
    Copying install file...
    0% copied.
    .....
    100% copied.
    Installing application...
    Could not install from package C:\Data\test_gcce_urel.sisx on device: General OS-related error
    Finished.

  7. #7
    Registered User
    Join Date
    Feb 2011
    Posts
    1

    Re: "Could not start application: General OS-related error" - When deploying on devic

    i came across to the same problem, and found out this could be solved by installing the "QT Mobility" onto the cellphone, even I didn't use any Mobility functions.
    Further, I noticed there have been some posts for the
    ":: warning: The Symbian toolchain does not handle special characters in a project path well."
    problem without a good solution. After 2 hours try-and-error, I noticed that the builder for Symbian does not like space, numeric, special characters at all, and the same warning message is shown when you create the project at the beginning (by telling the location of the resources and cpp...etc files). Though the builder wouldn't give accurate message.

Similar Threads

  1. Replies: 0
    Last Post: 2010-01-06, 10:58
  2. Replies: 3
    Last Post: 2009-12-06, 05:30
  3. Bluetooth Security: What exactly is an untrusted device?
    By rahulmcs in forum Bluetooth Technology
    Replies: 1
    Last Post: 2005-12-02, 06:26
  4. Auto start application related question
    By white_dragon in forum Symbian
    Replies: 1
    Last Post: 2005-01-27, 07:37
  5. Replies: 3
    Last Post: 2003-04-09, 18:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×