×

Discussion Board

Results 1 to 5 of 5

Thread: TTimer problem

  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    279

    TTimer problem

    Hi everybody
    please could anybody help me to solve this problem
    i want to make a base datetime in my application which will be at Saturday 12:00Am to make the application does a certain process every week at this time
    All the problem i have is to determine this time
    is there any approach to do that
    thanks in advance
    Ram4Soft

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: TTimer problem

    Check if RScheduler can do that, you can read about it in the Wiki.

  3. #3
    Nokia Developer Champion
    Join Date
    Jul 2004
    Posts
    2,015

    Re: TTimer problem

    Rscheduler is for starting a program that isn't already started, if your code is already running you can use RTimer/CTimer

  4. #4
    Super Contributor
    Join Date
    May 2006
    Location
    Beijing,China
    Posts
    1,190

    Re: TTimer problem

    TTime also can be used to calculate the time difference.
    [I][COLOR="Orange"]xhsoldier[/COLOR][/I]
    [email]xhsoldier@gmail.com[/email]/[email]xhsoldier@163.com[/email]

  5. #5
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: TTimer problem

    If you use TTime with RTimer then remember to consider the status iStatus.Int(). Many times you get KErrAbort as iStatus and you need to issue new request.

Similar Threads

  1. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  2. SyncML link problem
    By samuel_ in forum Symbian
    Replies: 4
    Last Post: 2009-03-27, 08:02
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×