×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 25
  1. #1
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Application does not open on icon click

    Hi,
    I have an application which works fine on N78.On installing it on E71,the installation is successful.But on clicking on the icon in Installations folder of the device nothing happens.Even the default processing icon(a circle) does not show up near the icon.
    Any ideas????

    Regards
    Biju Chandran
    Last edited by chandran.biju007; 2010-05-17 at 04:14.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Application does not open on icon click


  3. #3
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    Hi Yucca,
    Ok..Will put ErrRd...And tell

  4. #4
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    Yucca,
    It shows System Error(-1)

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Application does not open on icon click

    the see what you forgot to add to the pkg, you been here long enough to know what -1 means (KerrNotFound).

  6. #6
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    KErrNotFound -1 Unable to find the specified object
    I would like to debug and find where exactly the error occurs.

    But when creating a new debug configuration for E71 Carbide does not show the list of available remote agent installers for the TRK.Hence am not able to install one and do the on device debugging.
    Carbide says.No installer data available.Server might be down.

    Also my assumption is even if the app enters the Application class the processing icon(the moving circle) should show besides the application icon in the application manager of the device atleast for a brief moment before the app crashes.
    But absolutely nothing happens on clicking the icon.Any idea as to what could possible be causing the crash.

    Regards
    Biju Chandran

  7. #7
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    The pkg seems fine.Can't figure anything wrong here
    Code:
    ; App.pkg
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ; Also, the resource file entries should be changed to match the language
    ; used in the build. For example, if building for LANGUAGE_01, change the file
    ; extensions .rsc to .r01.
    ;
    ;Language - standard language definitions
    &EN
    
    ; standard SIS file header
    #{"App"},(0xE2A070E0),1,0,0
    
    ;Localised Vendor name
    %{"Vendor-EN"}
    
    ;Unique Vendor name
    :"Vendor"
    
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    
    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\App.exe"		-"!:\sys\bin\App.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\App.r01"		-"!:\resource\apps\App.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\App_reg.r01"	-"!:\private\10003a3f\import\apps\App_reg.r01"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\App_aif.mif" -"!:\resource\apps\App_aif.mif"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\App.mbm" -"!:\resource\apps\App.mbm"
    
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\Engine.dll"		-"!:\sys\bin\Engine.dll"
    ; Add any installation notes if applicable
    ;"App.txt"					  -"!:\private\0xE2A070E0\App.txt"
    And also the same works fine on N78 device.Had it been a package issue should it not give problems on all installations.

  8. #8
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Application does not open on icon click

    then I would suggest you to try debugging and seeing on which line of your code is leaving with this error. Basically would first concentrate on checking what happens in AppUi's contruction function.

  9. #9
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Application does not open on icon click

    ya you can try with logging something in a ConstructL of you AppUi and then proceed ahead.

  10. #10
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    Ok am stuck here.
    I am unable to do on device debugging because of the reasons i have stated before in this chain
    I then turned to
    http://wiki.forum.nokia.com/index.ph...ebug_log_files

    It creates the log file in the emulator.But on device
    I created the Logs folder in the phone root memory and MYAPP folder inside that.But log file is not created.
    What is the equivalent path for Logs on device??

  11. #11
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Application does not open on icon click

    Visible "Phone root" is c:\Data, did you try that one?

  12. #12
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    I am not sure i understand your question wizard.
    But on opening File Manager i get the phone root memory where i see folders like Documents,Games,Images,Installed Files,Other,Sound clips.
    I created a Logs folder here and inside that MYAPP folder

  13. #13
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Application does not open on icon click

    Quote Originally Posted by chandran.biju007 View Post
    I am not sure i understand your question wizard.
    But on opening File Manager i get the phone root memory where i see folders like Documents,Games,Images,Installed Files,Other,Sound clips.
    I created a Logs folder here and inside that MYAPP folder
    he is asking you to look into that specific folder, to see whether the logs are there..

  14. #14
    Super Contributor
    Join Date
    Nov 2008
    Posts
    675

    Re: Application does not open on icon click

    Phone root memory/Logs/MYAPP/
    does not have the log files.

    My question is what is C:/Data equivalent on Device.
    If it is the phone root memory then like i mentioned log files are not created there.
    If it is not then please advise how to browse to that location

  15. #15
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Application does not open on icon click

    dunno really, I have never used the real logger API, instead you could also try using RFile.. Then you can put teh file where ever you ant to.

Similar Threads

  1. Open C FAQ
    By Nokia Ron in forum Open C/C++
    Replies: 4
    Last Post: 2010-10-01, 09:02
  2. Replies: 4
    Last Post: 2010-03-01, 09:51
  3. Changing Application Icon on the Device
    By soofika in forum Symbian User Interface
    Replies: 1
    Last Post: 2009-10-21, 05:21
  4. Application icon not displayed until reboot
    By henranto in forum Symbian
    Replies: 7
    Last Post: 2008-07-01, 16:19
  5. Application icon does not show on phone
    By hduplessis in forum Symbian User Interface
    Replies: 2
    Last Post: 2008-04-04, 13:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×