×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    2

    Question Tactile feedback N97 not working

    Hi all,

    I am trying to build a WRT app for the N97 mini where the phone will vibrate depending on the user actions.

    To test how it works I have downloaded and deployed the example How_to_declaratively_add_tactile_feedback_in_WRT_widgets to my phone but it did not work

    Then I thought that because I am using the platform services 2.0 Javascript I should retrieve the sysinfo by calling
    Code:
    sysinfo = nokia.device.load("sysinfo");
    .. but did not have any luck

    If someone could help me it will be great, i started to loose my hair

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Tactile feedback N97 not working

    Hello isydor and welcome to the forum!

    Please make sure that you have vibrating alert turned on in your current profile.

    At least the tactile feedback works as described in the article on my n97

    Br,
    Ilkka

  3. #3
    Registered User
    Join Date
    May 2010
    Posts
    2

    Re: Tactile feedback N97 not working

    Hi,

    The vibration is turned on for sure, did you make any changes to the code?

  4. #4
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,098

    Re: Tactile feedback N97 not working

    Quote Originally Posted by isydor View Post
    Hi,

    The vibration is turned on for sure, did you make any changes to the code?

    Hello isydor,

    I have also tested the widget in the wiki article on my N97, latest device updater given software version v.21.0.045, RM-505, dated 14-01-10.

    I can verify successfully receiving vibrating feedback from two of the first elements, none from the third (no feedback value defined).

    Code:
    <body onLoad="javascript:init();">
    		<div id="element_1" feedback="100" style="width: 200px; height: 100px; background: red;"></div>
     
    		<div id="element_2"  feedback="50" style="width: 200px; height: 100px; background: green;"></div>
     
    		<div id="element_3" style="width: 200px; height: 100px; background: blue;"></div>
    </body>
    This brings us back to the problem why that would not be happening in your widget.

    Please once more check:

    Code:
    - type in *#0000 and check that your sw is the latest.
    
    - Reinstall and run the widget at:
      http://wiki.forum.nokia.com/index.ph...in_WRT_widgets)
    
    - Turn ON the vibrating alert in your current profile
    
    - Start the widget
    
    - Report back the result
    Let's take the troubleshooting further from there.


    Best Regards,
    [FONT="Comic Sans MS"][COLOR="Blue"][/COLOR][I]Marko Lumivuori
    Technical Support
    +358 40 8019330
    [email]marko.lumivuori@nokia.com[/email][/I][/FONT]

Similar Threads

  1. SetTime is not working in add call log event
    By keerthi.ck06 in forum Symbian
    Replies: 4
    Last Post: 2010-03-19, 01:03
  2. N97 Emulator in SDK issue
    By raf1hh in forum Symbian
    Replies: 3
    Last Post: 2009-06-19, 17:43
  3. Replies: 2
    Last Post: 2007-11-10, 13:19
  4. 7650 / BlueUSB Bluetooth USB dongle / PC-suite not working!
    By mahaikol in forum Bluetooth Technology
    Replies: 7
    Last Post: 2002-12-28, 06:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×