×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Apr 2010
    Posts
    131

    Angry [moved] Emulator: API not supported

    Can any body tell how to come out from this error in emulator??

    I am using S60 3rd edition FP2 V1.1

    When I run Symbian example application on Carbide.C++ 2.3.0 IDE's emulator it shows error

    Emulator: API not supported

    How to come up from this issue.

    Expecting immediate reply from...

    Rohit Shah

  2. #2
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Rohit Shah-> Emulator: API not supported

    What example you are running?
    Have you selected the SDK as default and have you set it's EPOCROOT?

  3. #3
    Regular Contributor
    Join Date
    Apr 2010
    Posts
    131

    Angry Re: Rohit Shah-> Emulator: API not supported

    I have only single SDK installed in same drive at where Carbide.C++ is installed.

    I have used Telephony example to dial a number.

    At the time of compiling I am not seeing any error related to EPOCROOT.

    Pls give your comments.

    Rohit Shah

  4. #4
    Super Contributor
    Join Date
    Aug 2005
    Location
    india
    Posts
    2,078

    Re: Rohit Shah-> Emulator: API not supported

    Hi,

    Emulator doesn't support the all etel plugins required to make a call from emulator. You need to install your application sis file on device as check your application.

    Regards,
    Mateen Maldar
    "Whatever the mind can conceive and believe, the mind can achieve"

  5. #5
    Regular Contributor
    Join Date
    Apr 2010
    Posts
    131

    Angry Re: Rohit Shah-> Emulator: API not supported

    This is fine but I am not able to install sis file on because of certification issus.

    When I am istalling sisx file it shows "Required application access not granted"

    What to do?....

    I want to make application which can dial number which is fixed in application and can handle Dialing, Ringing, Connected, Send DTMF in mature call and lastly to terminate the call.

    For this I am analyzing example but not getting much idea of how to do all this stuff in Symbian S60 3rd ed FP2 and getting errors as above..

    Can any body help me. I am very fresh to all this stuffs....

    Rohit Shah

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Rohit Shah-> Emulator: API not supported

    Ok, let's take it from the start.

    When you log in to this discussion board, on the left side menu you have a "My profile" link, and once you click on it you will be able to list all the threads you have started, or all the posts you have contributed on these forums. There's no need to put your name in the title.

    Your problem seems to be emulator related, but the emulator is part of the SDK and has nothing to do with the Carbide.c++ IDE

    Your initial query was about "Emulator: API not supported", and as far as I know there is no such error message anywhere in the SDK. Is that still a problem?

    Now you are saying that when installing the sis file [on device] it shows "Required application access not granted" which, as you can find from The ultimate* software installer debug guide (see link at the end for more help) the issue is simply that you are using more capabilities than your signing certificate allows you to. You can read the Platform Security chapter to learn about capabilities and have a look in the *.mmp file to see which ones you are using and then decide which type of certificate you should use for signing.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. [moved] Opengl ES 1.1 feature not supported..
    By RapchikProgrammer in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2009-12-11, 09:50
  2. [Moved] Install error: version not supported
    By saurabh.murhekar in forum Mobile Java General
    Replies: 4
    Last Post: 2009-09-22, 06:31
  3. Replies: 4
    Last Post: 2009-07-13, 08:36
  4. [moved] what devices are supported on SDK version: Nokia N97 0.5?
    By dinhtrungac in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2009-07-13, 07:08
  5. [moved] Is ETEL supported by S60 5th ed?
    By Sergey_Burish in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2009-04-13, 08:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×