×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    15

    [moved] Re: Build Env problems

    Quote Originally Posted by ltomuta View Post
    Reinstalling the SDK is not always a smart idea. If nothing else it is a major waste of time. The installer for the GCCE compiler (i.e. CSL Arm Toolchain) can be found in \Epoc32\tools\distrib\arm-none-symbianelf-2005-q1c.exe

    Although you do not mention it I suspect you are using the SDK on Windows Vista and that you are yet another victim of its File Virtualization feature. See http://wiki.forum.nokia.com/index.ph...Virtualization
    can you help me debug it

    ***Building project "cgf" for configuration "Emulator Debug (WINSCW) [S60_5th_Edition_SDK_v1.0]"

    ***Printing environment variables modified from default:
    MWCSYM2INCLUDES=C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_Common\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_Win32\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_X86;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C++\MSL_Common\Include;+C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Common\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Win32\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\Win32-x86 Support\Headers\Win32 SDK;
    PATH=C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Tools\Command_Line_Tools;I:\ProgramFiles\S60_5th\S60_5th_Edition_SDK_v1.0\epoc32\tools;I:\ProgramFiles\S60_5th\S60_5th_Edition_SDK_v1.0\epoc32\gcc\bin;C:/Program Files/Nokia/Carbide.c++ v2.3/jre/bin/client;C:/Program Files/Nokia/Carbide.c++ v2.3/jre/bin;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Tools\Command_Line_Tools;C:\Program Files\PC Connectivity Solution\;C:\Perl\site\bin;C:\Perl\bin;C:\Program Files\Windows Resource Kits\Tools\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\Lenovo\Bluetooth Software\;I:\ProgramFiles\QtCreator4_62\mingw\bin;C:\Program Files\Rational\common;C:\Program Files\Common Files\Symbian\tools;C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\bin;C:\Program Files\CSL Arm Toolchain\libexec\gcc\arm-none-symbianelf\3.4.3;C:\Perl\bin
    MWCINCLUDES=C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_Common\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_Win32\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_X86;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_C++\MSL_Common\Include;+C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Common\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Win32\Include;C:\Program Files\Nokia\Carbide.c++ v2.3\x86Build\Symbian_Support\Win32-x86 Support\Headers\Win32 SDK;
    EPOCROOT=\ProgramFiles\S60_5th\S60_5th_Edition_SDK_v1.0\
    NO_DEPENDENCIES=-nd
    MAKE=make -j 4

    Working Directory: I:/SourceMobile/cgf/group


    ***Invoking bldmake command
    perl.exe -S bldmake.pl bldfiles winscw
    Sorry, \epoc32\tools\bldmake.bat is not supported in this release. Please use a different
    device. Use 'devices' to view the available devices.


    === BLDMAKE Command failed with error code 2 ===
    ***Stopping. Check the Problems view or Console output for errors.


    ***Errors were detected in build. See the Problems or Console view for details.

    Total Time: 0 sec

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Re: Build Env problems

    You should have installed the SDK at the location suggested by the installer (c:\S60\) or if you chose a customized location that should be without space in the file path.

    Have you set EPOCROOT as \ProgramFiles\S60_5th\S60_5th_Edition_SDK_v1.0\ by hand? Where did the space in "Program Files" go?

    If you have EPOCROOT set in your system, remove it. Then move the content of c:\Program Files\S60_5th\S60_5th_Edition_SDK_v1.0\ to c:\S60_5th\S60_5th_Edition_SDK_v1.0 and edit c:\Program Files\Common Files\devices.xml to reflect this change.

    Start Carbide.c++ and if it detects the SDK change, re-start it when prompted. If it doesn't, inspect its SDK settings and make the required updates manually.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    May 2010
    Posts
    15

    Re: [moved] Re: Build Env problems

    Quote Originally Posted by ltomuta View Post
    You should have installed the SDK at the location suggested by the installer (c:\S60\) or if you chose a customized location that should be without space in the file path.

    Have you set EPOCROOT as \ProgramFiles\S60_5th\S60_5th_Edition_SDK_v1.0\ by hand? Where did the space in "Program Files" go?

    If you have EPOCROOT set in your system, remove it. Then move the content of c:\Program Files\S60_5th\S60_5th_Edition_SDK_v1.0\ to c:\S60_5th\S60_5th_Edition_SDK_v1.0 and edit c:\Program Files\Common Files\devices.xml to reflect this change.

    Start Carbide.c++ and if it detects the SDK change, re-start it when prompted. If it doesn't, inspect its SDK settings and make the required updates manually.

    why when i Configure environment for winscw command line it message

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: [moved] Re: Build Env problems

    Because you have probably called it 100 times already.

Similar Threads

  1. Build Env problems
    By sree1072 in forum Symbian Tools & SDKs
    Replies: 11
    Last Post: 2011-02-05, 14:47
  2. Replies: 0
    Last Post: 2010-01-26, 07:46
  3. [moved] Problems with post query
    By NRK in forum Symbian Networking & Messaging (Closed)
    Replies: 6
    Last Post: 2009-12-21, 10:33
  4. [moved] Problems in GUI while using S60 2nd
    By kalgi in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2009-02-27, 08:41
  5. SDK build 10 problems.
    By topisystems in forum Multimodecards
    Replies: 1
    Last Post: 2002-09-24, 14:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×