×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    26

    Question Is flash supported?

    Is there a way to load a flash app within QT for maemo? Webkit ? QAxWidget? Browser?

    Thank you,

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Is flash supported?

    WebKit supports loading Gecko plugins and there is adobe-flashplayer package containing flash plugin used by MicorB.

  3. #3
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Is flash supported?

    Check out this sample application
    Code:
    #include <QtGui>
    #include <QtWebKit>
    
    int main(int argc, char * argv[])
    {
        QApplication app(argc, argv);
    
        QWebView view;
        view.settings()->setAttribute(QWebSettings::PluginsEnabled, true); 
        view.load(QUrl("http://www.youtube.com/watch?v=KMU0tzLwhbE"));
        view.show();
    
        return app.exec();
    }

  4. #4
    Registered User
    Join Date
    Mar 2008
    Posts
    26

    Re: Is flash supported?

    UNBELIEVABLE!!! Tks man, that did the trick so much more easier than I expected!!!

    By the way, nice youtuve video ;-)

  5. #5
    Registered User
    Join Date
    Aug 2010
    Posts
    26

    Re: Is flash supported?

    Quote Originally Posted by divanov View Post
    WebKit supports loading Gecko plugins and there is adobe-flashplayer package containing flash plugin used by MicorB.
    dint work for me!
    I dont unserstand the line - "there is adobe-flashplayer package containing flash plugin used by MicorB". Do I need to add an extra package to my application to make it work?

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Is flash supported?

    No, you don't need to install any extra package. Qt Webkit makes use of Mozzilla plugins, and flash is shipped with the device.
    Last edited by gnuton; 2010-11-21 at 22:17.

  7. #7
    Registered User
    Join Date
    Aug 2010
    Posts
    26

    Re: Is flash supported?

    I just tried visiting my target page using the web browser on my phone and it works. But when I try visiting it using QWebview in my application I just get a symbol that looks like a lego box with a quesiton mark on it. Any suggesstion?

  8. #8
    Registered User
    Join Date
    Aug 2010
    Posts
    26

    Re: Is flash supported?

    I looked at another nokia forumn post by symbianyucca and here is what he says,
    "You can not use Flash-plug-in in any other app than those that have Nokia vendor UID with their process, thus it is only usable in normal Browser (propably not available in any 3rd party browser) as well as in WRT Widget applications."
    link to thread - http://discussion.forum.nokia.com/fo...sh-lite-plugin
    For the guys this is working for, did u already get your app approved and signed by nokia?

  9. #9
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Is flash supported?

    Quote Originally Posted by aasoftware View Post
    I looked at another nokia forumn post by symbianyucca and here is what he says,
    "You can not use Flash-plug-in in any other app than those that have Nokia vendor UID with their process, thus it is only usable in normal Browser (propably not available in any 3rd party browser) as well as in WRT Widget applications."
    link to thread - http://discussion.forum.nokia.com/fo...sh-lite-plugin
    For the guys this is working for, did u already get your app approved and signed by nokia?
    He was talking about Symbian.

  10. #10
    Registered User
    Join Date
    Nov 2010
    Posts
    79

    Re: Is flash supported?

    yes i also want to try to do this

Similar Threads

  1. Is Audio / video streaming supported in Widget
    By aahirve in forum Symbian Web Runtime
    Replies: 12
    Last Post: 2010-05-29, 15:33
  2. Want Startup in Flash Lite
    By syedshakeel2004 in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2009-06-10, 14:46
  3. Should devices with Flash Lite 2.1 (especially Nokia 3120 classic) support XMLSocket?
    By antti.moilanen in forum [Archived] Flash Lite on Nokia Devices
    Replies: 6
    Last Post: 2009-05-14, 20:47
  4. N95 force to Flash Lite 3.0 during start of application
    By maneesh.panwar in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2008-09-24, 07:48
  5. Internet problems
    By Aamirrasool in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2008-08-24, 09:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •