×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    22

    How to make N97 application compatible with N95?

    Hi Guys,

    I already developed the application, as I have no device that I can't able to test the application on Device.

    But there is a comment from client that the application is not compatible with N95 ?

    Can anyone please help me how can I make the application compatible with the N95?

    Thanks & Regards,
    Amit Doshi

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: How to make N97 application compatible with N95?

    Which application it is ? what APIs it is using ?

    As this is in WRT section, I suppose it is WRT applciation. So you should first check that the N95 has firmware that supports WRT widgets, and then you should only use APIs supported by the N95, which indeed excludes all platform service APIs.

  3. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    22

    Re: How to make N97 application compatible with N95?

    Thanks for reply..

    I am just developing application in Aptana using nokia wrt plugins on that ....

    With the use of Jquery, html and css.

    I am not aware about the compatiblity of the mobiles...

    Can you please guide me

    Thanks & Regards,
    Amit Doshi

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: How to make N97 application compatible with N95?

    then do check the firmware version of the N95, whether it supports WRT widgets, I'm having some network problems, so can not find the actual firmware version required, but you should be able to find it with bit of searching.

  5. #5
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,569

    Re: How to make N97 application compatible with N95?

    If my memory serves me right, for the N95, the first firmware version with WRT 1.0 was v21.something.

    Any firmware versions before that (v10, v11, v12, v13, v14, v20) do not support WRT widgets at all. I.e., the device must then have v21, v30 or v31 firmware for widgets to work.

    Note also, that there are multiple versions of Nokia's WRT implementation for both S60 3rd Edition FP1 and FP2 devices, as well as S60 5th Edition devices. The newer WRT versions support more/new things than the initial versions, so all widgets do not work on all models with WRT support, and depending on the firmware/WRT version on a single model, the behaviour might still vary even if it is the same hardware you're using.

Similar Threads

  1. Replies: 5
    Last Post: 2010-02-12, 07:16
  2. Trying to build a HelloWorld Application
    By Zarnick in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 10
    Last Post: 2009-07-15, 21:57
  3. EUserHL - application not compatible with the phone
    By gosuwachu in forum Symbian Tools & SDKs
    Replies: 14
    Last Post: 2009-06-04, 16:00
  4. Replies: 1
    Last Post: 2008-05-08, 12:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×