×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    3

    Exclamation Nokia 6300 Development with JavaME

    Hey guys!

    I just wanted to start creating a little program written in Java for my Nokia 6300.
    I know how to program in JavaSE, however, gonna have to get into JavaME in order to program for my mobile device, as I see.

    As IDEs, I use Eclipse and Netbeans. I installed JavaME in Netbeans, but then as I was creating a new JavaME-Project, it asked me for a JavaME-platform.

    As I found out, I need the Series 40 Platform SDK 5th Edition Feature Pack 1 for my Nokia 6300.
    I went here to download it, however, found out that this is an *.exe - installer for windows. I use MacOSX, though.

    So I went to the sun-webpage and downloaded Java ME SDK 3.0 for Mac OS from java.sun.com.

    Opened it, created a HelloWorld-Projekt, sent it to my Cellphone via Bluetooth, tried to open it with my cell, but it told me "Invalid program. Delete?".


    So I guess I need some SDK that is designed for this specific series (S40). Right?
    What can I do? Can anyone help me plz?
    I just want to start writing a program that will actually work on my phone, and I hope I wont have days of all kinds of configuration ahead of me before I can do that.
    So I guess my problem is that I found the right SDK (as it is in the link above), however not for my OS, just for Windows.

    Thank you in advance for your help,

    Jack
    Last edited by AlligatorJack; 2010-05-26 at 22:13.

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: Nokia 6300 Development with JavaME

    Hello Jack,

    and welcome to Forum Nokia Discussion Boards!

    So I guess my problem is that I found the right SDK (as it is in the link above), however not for my OS, just for Windows.
    Based on your description, this would seem to be the case, unfortunately.

    However, just in case of need to recheck, may I suggest to you have a look on this 'Getting started' guide available on Forum Nokia Java Developer's Library:

    Java Developer's Library 3.5 > Getting started

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Registered User
    Join Date
    May 2010
    Posts
    3

    Re: Nokia 6300 Development with JavaME

    Quote Originally Posted by r2j7 View Post
    Hello Jack,

    and welcome to Forum Nokia Discussion Boards!



    Based on your description, this would seem to be the case, unfortunately.

    However, just in case of need to recheck, may I suggest to you have a look on this 'Getting started' guide available on Forum Nokia Java Developer's Library:

    Java Developer's Library 3.5 > Getting started

    Regards,
    r2j7
    Hey.
    Thanks for your help and for welcoming me here
    I looked at it and did what it said.
    Still doesnt work on my Mac, tho, of course, since it doesnt give me any SDK for the S40 for my Mac Any solutions?

    Anyways, since I wanted to try it out now anyways, I tried it on my PC (Windows 7) for now.
    I did as the tutorial said (created HelloWorld-Application), however, after putting it on my device, it says "invalid program. Delete?".
    What do I do?
    As I said, I got a Nokia 6300.
    If I go to my software details in my cellphone, it tells me:

    "V 07.00
    19-08-08
    RM-217
    (c) Nokia."

    And in my Netbeans-Projekt I selected a JavaME-application with the following settings:
    Select Platform Type: CLDC/MIDP
    Emulator Platform: Series 40 5th Edition SDK, Feature Pack 1
    Device Configuration CLDC-1.1
    Device-Profile: MIDP-2.1


    What did I do wrong?
    Are those settings correct for the phone I got?

    PS: Even my Emulator on my PC gave me the same message "invalid program. Delete?".
    If I use the default-helloworld-code given by netbeans (instead of the one from this "get-started website"), the emulator doesnt show me that message, it will work. My cellphone will still give me that message, though.

  4. #4
    Registered User
    Join Date
    May 2010
    Posts
    3

    Re: Nokia 6300 Development with JavaME

    Noone here to help me? ^^

    I mean, it's not like the 6300 was a phone that was hardly sold^^
    Almost every other person has got this phone it seems

    Please !

  5. #5
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Nokia 6300 Development with JavaME

    You don't need a Nokia-specific SDK.

    Here is the specification for your phone.

    Here is a guide to common MIDlet installation problems.

    You'll see from the spec that your device supports MIDP-2.0, not 2.1. If you're application's JAD and/or MANIFEST specify MIDP-2.1, then the phone will reject the application, because it will think that it can't run the app.

    Hope these help some.

    Graham.

  6. #6
    Registered User
    Join Date
    Apr 2012
    Posts
    1

    Re: Nokia 6300 Development with JavaME

    launch this SDK via Parallels

  7. #7
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: Nokia 6300 Development with JavaME

    Hello Waru,

    and welcome to Nokia Developer Discussion Boards!

    The latest SDKs for Java ME development on Nokia's Series 40 devices can be found from here:

    http://www.developer.nokia.com/Devel...platform_SDKs/

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

Similar Threads

  1. Java Compability
    By emax73 in forum General Development Questions
    Replies: 0
    Last Post: 2004-07-12, 14:56
  2. Nokia Mobile VPN Client
    By marcyl in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2003-12-01, 14:47
  3. Nokia 7650 support Bluetooth audo?
    By ovjo12 in forum Bluetooth Technology
    Replies: 5
    Last Post: 2003-07-17, 18:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×