×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    May 2008
    Location
    Switzerland - VS
    Posts
    81

    On device debug issues - unresolved breakpoint

    Hello,
    I recently switched to QT S60 to do my application, but I have some issues with the On Device Debug.

    By Searching a little I'm not the only one, but I didn't find any solution.

    Here is my dev env :
    Carbide 2.3
    QT 4.6.2
    Symbian sdk 3.2 V1 and 5th 1.0
    Last activ perl and python

    So here is the issue :
    When I run a On Device Debug, it's not possible to use breakpoint. All of them are "unresolved".

    step to reproduce :
    - create a new QT project with qt main windows or qt widget as project type.
    - select sdk 3.2 or 5th (I didn't try any other one, but I presume that the problem will be here too)
    - build the configuration (GCCE)
    - create a debug config for ODD
    - launch it.
    - All the breakpoint do you use are unresolvable. (some time in the main.cpp I'm able to place a working one. But there is no use to put a breakpoint in here...).


    Here is what I've already checked/tested :
    - create a new project without QT to see if the breakpoint works. (it's okay all is fine)
    - updated carbide to 2.5.0 (always same, but worst because in 2.5 the qt project file editor had a little bug while adding new files)
    - checked the .map file to see if all the files was referenced in it. (yes they are)
    - tested on N78 and E71
    - Verified the debug config
    - In the emulator all is fine.

    So someone has any idea about how to fix it ? or did the ODD with GCCE works for someone ?

    --
    Some times I also have another strange thing. It's impossible to start the debug. I've got a empty error message about com.nokia.cdt.debug.launch plugin (In the error log of carbide).
    Here is the error log :

    eclipse.buildId=unknown
    java.version=1.6.0_16
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
    Command-line arguments: -os win32 -ws win32 -arch x86


    I can correct this second issue by changing the order of the sources files in my *.pro file but the breakpoint are always unresolvable. I put this little issue here because I thing it's perhaps linked with the first one.

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: On device debug issues - unresolved breakpoint

    Can you show with coding ?

    By the on the device debugging you can do using fifth edition devices by connecting them with PC.
    See the below article.

    http://wiki.forum.nokia.com/index.ph...ng_with_AppTRK

    Best regards,

  3. #3
    Regular Contributor
    Join Date
    May 2008
    Location
    Switzerland - VS
    Posts
    81

    Re: On device debug issues - unresolved breakpoint

    I use on device debug with usb cable & trk.

    I don't use QT creator. I need to use native symbian c++ code in my project, so I use carbide & qt for symbian 4.6.2 sdk. I tried with the last QT sdk + creator but the native functions I need wasn't available apparently (related to the camera).

    So I don't have a lot of code to show. Because you don't need more than the default carbide qt project created when you create a new project.

    I can perhaps try to use qt creator and using the path of the 4.6.2 sdk ? in that case I suppose that I'll have access the native function ?

  4. #4
    Regular Contributor
    Join Date
    May 2008
    Location
    Switzerland - VS
    Posts
    81

    Re: On device debug issues - unresolved breakpoint

    Some update about the issue.

    I've been able to have all my files debuggable by updatting GCC from 3.4.3 to 4.4.1, using a "how to" I found in the wikis. But There is some trouble with gcc 4.4.1 anyway. Some of the openc/c++ library arn't the same. So I can't run the software on the phone. The debugger prompt me the error message when I try ODD "application can't be installed or some library are missing". So, I can install the software, then it's some library. It's happend on some calls. For example the QQrDecoder (you can found on this website) will reproduce this error.

    So I'm realy stuck now because I have to use the camera and some other library in openc . I can't debug on emulator because of the camera code that will crash the emulator, I can debug on device, but only main.cpp, and if I switch to gcc 4.4.1 I can't debug anything because I can't launch the application.

  5. #5
    Registered User
    Join Date
    May 2009
    Location
    Greece
    Posts
    191

    Re: On device debug issues - unresolved breakpoint

    Hi there.

    This sounds to me like you haven't copied the camera library files contained to the project to the EPOC root folder.

    As mentioned to the wiki page of the QQrDecoder:
    Preconditions to use it for Symbian

    Inside the project folder, there is a folder named camerawrapper. Inside this, the epoc32 folder must be copied to the epoc32 folder of the Symbian SDK to be used!
    (in my case: C:\S60\devices\S60_5th_Edition_SDK_v1.0)
    Have you done this step?

Similar Threads

  1. How To debug application on device
    By prajapati.ajay in forum Mobile Java General
    Replies: 9
    Last Post: 2009-09-30, 03:48
  2. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  3. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14
  4. Using non-UI guided Bluetooth device inquiry -- issues
    By tkedem in forum Bluetooth Technology
    Replies: 1
    Last Post: 2003-03-30, 02:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×