×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    22

    problem in back and forth of LWUIT form and normal form in j2me

    I am attaching a small application link in which there is a problem in coming back from lwuit form to normal form.

    http://www.filefactory.com/file/b1ge...plication9.zip

    on execution
    Press Ok on lwuit
    press ok on normal
    press menu and select back in the last form

    on pressing back i want to go to normal form but it shows the normal form for some milliseconds.

    how to come out of this problem?

  2. #2
    Registered User
    Join Date
    Oct 2009
    Location
    Noida
    Posts
    941

    Re: problem in back and forth of LWUIT form and normal form in j2me

    on pressing back i want to go to normal form but it shows the normal form for some milliseconds.
    Issue is not very clear from above line, please re-frame.
    Thanks,
    Ekta

  3. #3
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: problem in back and forth of LWUIT form and normal form in j2me

    Quote Originally Posted by jugal.inani View Post
    Press Ok on lwuit
    press ok on normal
    press menu and select back in the last form

    on pressing back i want to go to normal form but it shows the normal form for some milliseconds.

    how to come out of this problem?
    And what happens after those milliseconds?
    And what is displayable at that time after these millis?
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  4. #4
    Registered User
    Join Date
    Apr 2010
    Posts
    22

    Re: problem in back and forth of LWUIT form and normal form in j2me

    on pressing back it remains on the same form except those milliseconds.
    The same code is working fine when we work with both LWUIT forms.

  5. #5
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: problem in back and forth of LWUIT form and normal form in j2me

    IS there any exception/error/alert when you are pressing back command?
    Are you sure that you have set the current displayable as the form on the back command?
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  6. #6
    Registered User
    Join Date
    Apr 2010
    Posts
    22

    Re: problem in back and forth of LWUIT form and normal form in j2me

    There is no error or exception here.
    ya i have set the current displayable on back command.

  7. #7
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: problem in back and forth of LWUIT form and normal form in j2me

    try to debug the code inside the commandAction()..put some sort of println statement and try to find out the reasons for the same.Oe even you can use a logger and write the steps and like this you can find that upton which line the control has came.
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  8. #8
    Registered User
    Join Date
    Apr 2010
    Posts
    22

    Re: problem in back and forth of LWUIT form and normal form in j2me

    ok I will try to debug but when i keep the current displayable on back command as LWUIT form instead of normal form it is working fine.

    Thank You Raj for helping me.

  9. #9
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: problem in back and forth of LWUIT form and normal form in j2me

    Quote Originally Posted by jugal.inani View Post
    ok I will try to debug but when i keep the current displayable on back command as LWUIT form instead of normal form it is working fine.
    Well that can be due to various reasons..
    1. Form is null,
    2.Form was not set currnet displayable
    3.The display object is of the LWUIT API and not of the LCDUI,
    Are you using the LWUIT Display to set the Form as the displayable?
    Try to use the LCDUI's display reference.
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •