×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jan 2009
    Posts
    19

    Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    Hi

    I installed Pulsar for Mobile Java Developers (Build id: 20090920-1017) based on Eclipse.

    Then I installed S60 3rd Edition SDK for Java downloaded from http://www.forum.nokia.com/info/sw.n..._for_Java.html.

    After that I selected controls [Window]->[Preferences]->[Java ME]->[Device Management]->[Import…]->[Browse…] -> [S60_3rd_MIDP_SDK folder] where I installed the SDK.

    Eclipse did not find available devices.

    It works fine for Series 40 6th Edition SDK and S60 5th Edition SDK.

    A lot of thanks for any suggestions.

    Sergey

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    Hello Sergey,

    in case the older S60 SDK cannot be found then couple of options could come in question:

    -according to S60 3rd Ed. SDK release notes, the Eclipse support has been verified for Eclipse 3.1.

    -instead of Eclipse, you could try with NetBeans (the release notes describe support for NetBeans IDE 5.0)

    -you could try with newer S60 SDK than S60 3rd Ed. SDK.


    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    Are you sure that the SDK in not corrupted and is working..by running going to the start->all programs..etc.?

    After that I selected controls [Window]->[Preferences]->[Java ME]->[Device Management]->[Import…]->[Browse…] -> [S60_3rd_MIDP_SDK folder] where I installed the SDK.
    Also tryo to give the root director of the SDK, like the D: or E: and let us know the results.
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  4. #4
    Registered User
    Join Date
    Jan 2009
    Posts
    19

    Re: Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    I installed SDK in C:\S60\devices\S60_3rd_MIDP_SDK. Does not it mean OK?

  5. #5
    Registered User
    Join Date
    Jan 2009
    Posts
    19

    Re: Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    I use Eclipse 3.5.1. Is it OK?
    I could use newer S60 SDK. It is no a problem.
    But how could I compile the project for old devices than?
    Thank you in advance.

  6. #6
    Registered User
    Join Date
    Oct 2009
    Location
    Noida
    Posts
    941

    Re: Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    Quote Originally Posted by ysaspb View Post
    I use Eclipse 3.5.1. Is it OK?
    I could use newer S60 SDK. It is no a problem.
    But how could I compile the project for old devices than?
    Thank you in advance.
    Compiling J2me code in new or old SDK does not effect its capabilities to run on new or old devices, you just need to set the MIDP & CLDC version for your target device correctly. On the safer side use MIDP 2.0 and CLDC 1.0 and your app will run on most of the S40 and S60 devices available in the market nowadays.
    Thanks,
    Ekta

  7. #7
    Registered User
    Join Date
    Nov 2010
    Posts
    3

    Re: Eclipse does not see installed S60 3rd Edition SDK for Java. What should I do?

    Quote Originally Posted by ektasrv View Post
    Compiling J2me code in new or old SDK does not effect its capabilities to run on new or old devices, you just need to set the MIDP & CLDC version for your target device correctly. On the safer side use MIDP 2.0 and CLDC 1.0 and your app will run on most of the S40 and S60 devices available in the market nowadays.
    I meet a surprising status when i installed s60 2nd MIDP SDK or 3rd MIDP SDK.
    The beginning of install progress is ok,but cannot finish normally when came to about 98% of progress,then only show "Installing...Uninstall_s60_3rd_MIDP_SDK" and seem to die here.
    My computer's OS is Win 7, and i have runned the setup used administrator account role.

    Has anybody meet this status too?and who can tell me how to resolve this problem?
    Thanks much~

Similar Threads

  1. Replies: 1
    Last Post: 2010-06-12, 10:33
  2. S60 3rd Edition FP1 Java SDK reports jar file error
    By Ruediger_23 in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2010-04-08, 17:21
  3. [Moved] error using sdk s60 3rd edition for java on netbeans
    By axe_lito in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2009-11-18, 09:40
  4. Replies: 3
    Last Post: 2009-01-05, 09:54
  5. S60 3rd Edition SDK maintenance release Java SDK
    By andresnokia in forum Mobile Java Tools & SDKs
    Replies: 7
    Last Post: 2008-06-23, 19:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×