×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    13

    QSensor failing to connect to Backend

    I upgraded the qt.sis and qtmobility.sis files on my Symbian device from 4.6.2 and 1.0.0 to 4.6.3 and 1.0.0(1), respectively. This was the result of upgrading from the Beta to the Release Candidate 1 version of Nokia Qt SDK. Now, however, the following attempt to connect to a sensor backend no longer succeeds.

    m_sensor = new QSensor("QAccelerometer");
    m_sensor->addFilter(this);
    if (m_sensor->connectToBackend())
    qDebug("Connected to Backend");
    else
    qDebug("Did not connect to Backend");


    Any ideas on why that might be? Thanks.

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QSensor failing to connect to Backend

    Backends are created on demands, so how to create the backends, See the below page :

    http://doc.qt.nokia.com/qtmobility-1...or-plugin.html

    Best regards,

  3. #3
    Registered User
    Join Date
    Jun 2010
    Posts
    13

    Re: QSensor failing to connect to Backend

    When QSensor::connectToBackend() is called, the createBackend() function will be called according to the QSensorManager documentation. Thanks for the link that shows how to create "MyPlugin" class. However, I am trying to use the plugin that is supposed to be included in the upgraded QtMobility that I installed on the Symbian device. The shown code snippet was working when the Beta Nokia Qt SDK was used.

  4. #4
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QSensor failing to connect to Backend

    Quote Originally Posted by sweedyar View Post
    When QSensor::connectToBackend() is called, the createBackend() function will be called according to the QSensorManager documentation. Thanks for the link that shows how to create "MyPlugin" class. However, I am trying to use the plugin that is supposed to be included in the upgraded QtMobility that I installed on the Symbian device. The shown code snippet was working when the Beta Nokia Qt SDK was used.
    Because the Qt SDK contains the inbuilt Qt mobility API, But for the device you have to add that Qt and Qt mobility libraries,

    Best regards,

  5. #5
    Registered User
    Join Date
    Jun 2010
    Posts
    13

    Re: QSensor failing to connect to Backend

    Thanks. As indicated in the initial post, I installed on the device both the new qt.sis and the new qtmobility.sis (i.e., 4.6.3 and 1.0.0(1)). Are you referring to something else that should be added to the device?

Similar Threads

  1. error: 'QSensor' was not declared in this scope
    By mextil in forum [Archived] Qt Mobility Project
    Replies: 5
    Last Post: 2011-08-03, 14:52
  2. QSensor compilation problem
    By alenon in forum [Archived] Qt Mobility Project
    Replies: 2
    Last Post: 2010-05-21, 11:47
  3. how to use symbian as backend in flash lite.
    By navneet.gupta in forum [Archived] Flash Lite on Nokia Devices
    Replies: 3
    Last Post: 2008-10-15, 18:15
  4. Nokia Mobile Web Server failing to connect
    By BharatBedi in forum Mobile Web Server
    Replies: 4
    Last Post: 2008-08-19, 15:25
  5. Failing to connect to emulator
    By whitecf in forum General Messaging
    Replies: 2
    Last Post: 2003-04-04, 12:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×