×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Apr 2010
    Location
    Fortaleza, Brazil
    Posts
    118

    Symbian^3 SDK v0.8: can't find application in emulator

    Hi all!

    I'm new to the Symbian world, and just installed the Nokia Symbian^3 SDK v0.8. The installation went fine and I followed item 5 of the installation guide (Verifying SDK Installation)... I built an application just fine, but I can't find it in the emulator!

    Here is what I did:

    • Opened the command prompt
    • Set Nokia Symbian^SDK as the default device:
      ?> devices -setdefault @Nokia_Symbian3_SDK_v0.8:com.nokia.s60
      ?> devices
      Nokia_Symbian3_SDK_v0.8:com.nokia.s60 - default
    • ?> cd \Nokia\devices\Nokia_Symbian3_SDK_v0.8\examples\symbian\gui\helloworldbasic\group
    • ?> bldmake bldfiles
    • ?> abld build

      There were no errors during the build, but many warnings (like 'warning: no newline at end of file' and 'warning: "/*" within comment').

    Every time I start epoc, after about 4 min. it displays the message:
    Memory low. Delete or
    move some data from C:
    Phone memory.
    But the emulation continues without any other problem. On the emulator keyboard I click a button that shows a menu with the "Applications" button. I click "Applications" and the following list appears:
    Calculator, Clock, Converter, Notes, Recorder, Search,
    Log, Camera, User guide, Debug Agent, eshell, File mgr.,
    Mail, SW update, JavaCap, Location, Oper. menu, SimLockUI,
    TCKRunner, User Dict. and Radio.
    No "helloworldbasic" anywhere...

    I noticed many "HelloWorldBasic" files on the following directories under C:\Nokia\devices\Nokia_Symbian3_SDK_v0.8\epoc32\:
    data\z\private\10003a3f\import\apps\
    data\z\resource\apps\
    include\
    localisation\
    localisation\group\
    localisation\HelloWorldBasic\rsc\
    localisation\HelloWorldBasic_reg\
    release\gcce\udeb\
    release\gcce\urel\
    ... and also under C:\Nokia\devices\Nokia_Symbian3_SDK_v0.8\epoc32\BUILD\Nokia\devices\Nokia_Symbian3_SDK_v0.8\examples\symbian\gui\helloworldbasic\group\HELLOWORLDBASIC\:
    GCCE\
    GCCE\udeb
    GCCE\urel

    Could someone tell me what am I doing wrong? Where is the "helloworldbasic" application supposed to be available in the emulator?

    Thank you!

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,698

    Re: Symbian^3 SDK v0.8: can't find application in emulator

    Yes, it was reported already a couple weeks.
    GCCE is one of the target platforms for the actual devices, the emulator is actually in epoc32\release\winscw (for example the emulator itself is started via epoc.exe in that folder)
    Building for the emulator is not possible without installing Carbide.c++, and after the installation you will also have to execute the WINSCW configuration script from its start menu folder, in order to make the compiler accessible for command line usage.
    Note that while you will probably download Carbide.c++ version 2.3, its built-in updater (Help menu) can update it up to version 2.6.

  3. #3
    Regular Contributor
    Join Date
    Apr 2010
    Location
    Fortaleza, Brazil
    Posts
    118

    Unhappy Re: Symbian^3 SDK v0.8: can't find application in emulator

    Thanks, wizard_hu! I just did that.

    It's tiring having to jump through so many hoops, though... I've been downloading, configuring and installing SDKs, IDEs and APIs, and reading documentation from several sites, forums, wikis and blogs literally for days, and I'm still not sure if I'm following the right steps and in the right order (due to outdated and/or conflicting information and documentation). Now that I finally installed (and updated) Carbide I tried to build a simple Qt app, but many confusing and obfuscated errors (like "function call '[QBasicAtomicInt].q_atomic_increment({lval} volatile long *)' does not match") just makes me want to forget about Symbian and go back to Maemo.

    Sorry about the rant...

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,698

    Re: Symbian^3 SDK v0.8: can't find application in emulator

    Qt and Symbian C++ are rather different, however what you quoted is a part of a standard C++ error message (CDT still does not excel in parsing every kind of error messages, so you should check the complete messages in the Console tab of Carbide).

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Symbian^3 SDK v0.8: can't find application in emulator

    The Symbian^3 Platform SDK is version 0.8 (i.e. alpha), and there are no devices yet on the market supporting it. Plus, it is rather well hidden on the side too, with the Nokia Qt SDK being pushed strongly in front of the visiting developer, especially one new to Symbian. Despite of that you have obviously made a wrong choice. ;)

    My advice: give Nokia Qt SDK a try if you have time next week or download one of the mature SDKs (e.g. S60 5th Edition) for which both Carbide.c++ and Qt have full support. As for reading materials, blogs and stuff, you could simply start with http://tinyurl.com/StartSymbian
    Last edited by ltomuta; 2010-06-19 at 06:44.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Regular Contributor
    Join Date
    Apr 2010
    Location
    Fortaleza, Brazil
    Posts
    118

    Thumbs up Re: Symbian^3 SDK v0.8: can't find application in emulator

    Hi Lucian!

    Actually, my choice of SDK was driven by reasons that I can't comment for now...

    Quote Originally Posted by ltomuta View Post
    My advice: give Nokia Qt SDK a try
    I sure will. Thanks!

Similar Threads

  1. The difference between symbian^3 pdt and nokia symbian^3 sdk V0.8
    By datainfo11 in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2010-05-19, 07:42
  2. Cannot find application on 9.1 SDK Emulator
    By genyv74 in forum Symbian
    Replies: 5
    Last Post: 2007-07-19, 05:57
  3. Series 60 SDK for Symbian v0.9 - Cannot build binaries
    By theLauronen in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-19, 18:06
  4. Nokia 7650 v0.9 SDK emulator RAS broken, confirmed.
    By patstr in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-08-14, 10:41
  5. Almost all tools (S60 MIDP SDK B0.1, Nokia S60 SDK Symbian OS v0.3) Crashes
    By alexandershalamov in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-07-03, 13:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×