×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 28
  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    QtMobility1.0.1 probleme!!!

    Hi,

    I have made a application with Qt463 and QtMobility1.0.0
    with sdk s60v5 s60v31 and s60v32

    it run well on all device when i install Qt463 and QtMobility1.0.0.
    but i do'nt lunch if i use smart install with downlood QtMobility1.0.1

    the probleme is the application complied with QtMobility1.0.0 are not compatible with QtMobility1.0.1

    And the smart install give error.

    but if i remplace QtMobility1.0.1 with QtMobility1.0.0 it whork

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: QtMobility1.0.1 probleme!!!

    They are not binary compatible, so what's is the problem?

  3. #3
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: QtMobility1.0.1 probleme!!!

    The problem is when i use smart install to install my qt application, it downlood QtMobility 1.0.1 and not QtMobility 1.0.0 and so my application don't run.

  4. #4
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: QtMobility1.0.1 probleme!!!

    Quote Originally Posted by HAF.MED View Post
    The problem is when i use smart install to install my qt application, it downlood QtMobility 1.0.1 and not QtMobility 1.0.0 and so my application don't run.
    Then you should build your app against the new version! There are no other solutions...

  5. #5
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: QtMobility1.0.1 probleme!!!

    Hi,

    Thanks

    but where can i fin source of QtMobility1.0.1 to install it in SDK S60V5 and rebuild my application?

  6. #6
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: QtMobility1.0.1 probleme!!!

    Quote Originally Posted by HAF.MED View Post
    Hi,

    Thanks

    but where can i fin source of QtMobility1.0.1 to install it in SDK S60V5 and rebuild my application?
    Good question.. mobility 1.0.1 is not out yet.. but since there is already a package.. I suppose it will be out very very soon...

  7. #7
    Registered User
    Join Date
    Aug 2008
    Posts
    30

    Re: QtMobility1.0.1 probleme!!!

    My App also crash with mobility 1.0.1,but well with 1.0.0.

  8. #8
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: QtMobility1.0.1 probleme!!!

    Quote Originally Posted by DoiT View Post
    My App also crash with mobility 1.0.1,but well with 1.0.0.
    just out of curiosity, which Mobility module are you using? where does your application crash? does it happen in Multimedia?

  9. #9
    Registered User
    Join Date
    Aug 2008
    Posts
    30

    Re: QtMobility1.0.1 probleme!!!

    Hi, I use systeminfo, location & bearer no Multimedia. I write a example to test it. when build with 1.0.0. it's will not run on device which installed 1.0.1. After re-build with 1.0.1, my example will run well, except location module. any ideas? Thanks.

  10. #10
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: QtMobility1.0.1 probleme!!!

    Hi,

    I have the same probleme with location in OtMobility 1.0.1

    If I buid my application with need locaton with qt-mobility-symbian-opensource-1.0.1 it don't run if I install OtMobility 1.0.1 on my 5800xm
    but if i install OtMobility 1.0.0 it run well!!

    I have test the exemple satellitedialog, the same probleme like my application.


    I use S60_5th_Edition_SDK and qt-mobility-symbian-opensource-1.0.1 and Qt Creator 2.0.0

  11. #11
    Nokia Developer Expert
    Join Date
    Dec 2009
    Posts
    81

    Re: QtMobility1.0.1 probleme!!!

    It appears to be a packaging error - I'm looking into at the moment.

    A possible work around while we try to fix this is to build the package from source - I just tested with 1.0.1 built from source and the problem disappeared.

  12. #12
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: QtMobility1.0.1 probleme!!!

    Hi,

    but the qtmobility.sis ver 1.0.1 downlowd by smart installer let that Qt application build for QtMobility 1.0.1 don't run.

    where found solution?

    thanks

  13. #13
    Registered User
    Join Date
    Jun 2010
    Location
    UK
    Posts
    73

    Re: QtMobility1.0.1 probleme!!!

    I'm possibly having the same problem, since I'm trying to use Location module with the 1.0.1 sis file (also see http://bugreports.qt.nokia.com/browse/QTMOBILITY-360 ). However, I'm yet to figure out the workarounds.

    How do I get a 1.0.0 QtMobility.sis? The one that came with the original SDK ( Nokia_Qt_SDK_Win_offline_v1_0_en.exe ) is still reported as 1.00(1) (and I tested installing it anyway, and the application still didn't start). I tried building QtMobility 1.0.1 from source as suggested in the bug report - I ran "configure" then "make release-gcce", but this process didn't give me a sis file.

    I also tried rebuilding my application after I rebuilt QtMobility, as suggested by comments here, but that didn't work either.

    Any ideas? Thanks in advance.

    And is anyone else having these problems? Surely there must be more than two people using QtMobility

  14. #14
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: QtMobility1.0.1 probleme!!!

    The final release of the Nokia Qt SDK has Qt Mobility 1.0.1 and the same version of Qt Mobility is fetched by the smart installer, according to http://tinyurl.com/SmartInstaller
    If you build your application with the Nokia Qt SDK v1.0 final and distribute it with the Smart Installer it is expected to work on device. If your application is built with earlier Qt Mobility releases (like 1.0.0) it will not work and you must rebuild it.

    Does this answer the question?

    Update: I see now that there might be an additional problem with the LBT support in Qt Mobility. That is indeed a different story and if confirmed we need a new Qt Mobility release.
    Last edited by ltomuta; 2010-06-28 at 16:15. Reason: Updated
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  15. #15
    Registered User
    Join Date
    Jun 2010
    Posts
    6

    Re: QtMobility1.0.1 probleme!!!

    Hi,

    Excuse me but still application build with QtMobility 1.0.1 and Qt SDK v1.0 final if it need API location, don't run on device!!

    I have tested that on my 5800xm

Similar Threads

  1. Replies: 6
    Last Post: 2010-03-22, 12:38
  2. brightness probleme with the autofocus camera exemple
    By abbet.c in forum Symbian Media (Closed)
    Replies: 0
    Last Post: 2008-03-14, 14:53
  3. timer probleme
    By metosrs in forum Symbian
    Replies: 2
    Last Post: 2008-02-29, 07:26
  4. Probleme for read the sdcard on the nokia e61
    By mickael.bernard in forum Mobile Java General
    Replies: 1
    Last Post: 2006-11-25, 01:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •