×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Aug 2009
    Location
    Bangalore, India
    Posts
    454

    can't see video - only audio is audible

    Hi,
    I am using this (http://wiki.forum.nokia.com/index.ph...oPlayerUtility) for playing a video file.
    My application consists of 3 views. out of which, one is for creating the instance of MediaEngine.

    iMediaEngine = CMediaEngine::NewL( view2 );

    If I call iAppUi->iMediaEngine->InitControllerL(); from view1, it is playing the file with background as view1 and only audio can be audible. No other video frames are coming.

    Please anyone tell me what to refresh to play the video file correctly ?
    Regards,
    Sunitha.M

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: can't see video - only audio is audible

    The video is rendered to the non-existing window of "view2". You may rather want to create CMediaEngine locally in the currently active view/container.

  3. #3
    Regular Contributor
    Join Date
    Aug 2009
    Location
    Bangalore, India
    Posts
    454

    Re: can't see video - only audio is audible

    If I activate the view2 after calling InitControllerL, then video is displaying. But not sure whether this is a good idea or not.

    iAppUi->iMediaEngine->InitControllerL();
    iAppUi->ActivateLocalViewL(KView2Id);
    Regards,
    Sunitha.M

Similar Threads

  1. Replies: 5
    Last Post: 2010-06-04, 10:28
  2. Replies: 1
    Last Post: 2009-07-02, 12:03
  3. Audio voice not audible
    By Pallavi_K in forum Audio
    Replies: 0
    Last Post: 2008-12-17, 08:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×