×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    5

    QT Integration 1.6.2 crashes Eclipse Helios

    I upgraded QT from the downloaded 1.6.1 installation file to 1.6.2 in Eclipse.
    Everything appeared to be fine and I restarted Eclipse with the normal "start.bat".

    Whenever I try to view a .ui file or open the widget box, Eclipse silently crashes.
    I reverted back to 1.6.1 and that is working fine.

    Nathan

  2. #2
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: QT Integration 1.6.2 crashes Eclipse Helios

    Could you post the contents of your .log file, found under your workspace .metadata folder?

    Tim

  3. #3
    Registered User
    Join Date
    Jun 2010
    Posts
    5

    Re: QT Integration 1.6.2 crashes Eclipse Helios

    Sorry, I'm pretty new with Eclipse and didn't know where the .log file was.

    !SESSION 2010-06-23 20:55:19.427 -----------------------------------------------
    eclipse.buildId=I20100608-0911
    java.version=1.6.0_20
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
    Framework arguments: -product org.eclipse.epp.package.cpp.product
    Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.cpp.product -clean

    !ENTRY org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Warnings while parsing the key bindings from the 'org.eclipse.ui.commands' extension point
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.compileSource'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.buildProject'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.abldTarget'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.buildAllConfigs'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.cleanSymbianComponent'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.buildSymbianComponent'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.freezeSymbianComponent'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.buildProject'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.compileSource'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.buildProject'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.cpp.builder.utils.commands.compileSource'
    !SUBENTRY 1 org.eclipse.ui 2 0 2010-06-23 20:55:30.560
    !MESSAGE Cannot bind to an undefined command: plug-in='com.nokia.carbide.cpp', id='com.nokia.carbide.search.system.ui.openSystemSearchPage'

    !ENTRY com.nokia.carbide.cpp.sdk.core 2 2 2010-06-23 20:55:42.331
    !MESSAGE Perl v5.6.1 was not detected. Some SDKs do not work with other Perl versions.

    !ENTRY java.lang.ProcessBuilder 2 0 2010-06-23 20:55:42.841
    !MESSAGE Could not find or launch Raptor script 'sbs.bat'; SBSv2 support will not be available
    !STACK 0
    java.io.IOException: Cannot run program "sbs.bat": CreateProcess error=2, The system cannot find the file specified
    at java.lang.ProcessBuilder.start(Unknown Source)
    at java.lang.Runtime.exec(Unknown Source)
    at java.lang.Runtime.exec(Unknown Source)
    at com.nokia.carbide.cpp.internal.sdk.core.model.SDKManager.getSBSv2Version(SDKManager.java:986)
    at com.nokia.carbide.cpp.internal.sdk.core.model.SDKManager.scanSDKs(SDKManager.java:168)
    at com.nokia.carbide.cpp.internal.sdk.core.model.SDKManager.ensureScannedSDKs(SDKManager.java:242)
    at com.nokia.carbide.cpp.internal.sdk.core.model.SDKManager.getSDKList(SDKManager.java:257)
    at com.nokia.carbide.cpp.internal.sdk.ui.NewPluginChecker.checkForNewlyInstalledPlugins(NewPluginChecker.java:41)
    at com.nokia.carbide.cpp.sdk.ui.SDKUIPlugin.start(SDKUIPlugin.java:61)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)
    at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:913)
    at org.eclipse.core.internal.plugins.PluginDescriptor.doPluginActivation(PluginDescriptor.java:360)
    at org.eclipse.core.internal.plugins.PluginDescriptor.getPlugin(PluginDescriptor.java:340)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.ui.internal.EarlyStartupRunnable.getPluginForCompatibility(EarlyStartupRunnable.java:149)
    at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:73)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.ui.internal.Workbench$58.run(Workbench.java:2398)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
    at java.lang.ProcessImpl.create(Native Method)
    at java.lang.ProcessImpl.<init>(Unknown Source)
    at java.lang.ProcessImpl.start(Unknown Source)
    ... 27 more

    Now that I had my workbench set so the QT panels were open, Eclipse crashes immediately, so now I have to look into clearing out the workbench or changing the perspective somehow so I can revert back to 1.6.1.

    In addition, there was an issue with the "start.bat" from the Eclipse Integration installation regarding Perl not being found in the PATH.
    !ENTRY com.nokia.carbide.cpp.sdk.core 4 4 2010-06-23 20:45:18.527
    !MESSAGE Perl was not found on the PATH environment variable. Some tools will not function properly. Perl 5.6.1 is recommended for Carbide use (free download at www.activestate.com).
    !STACK 0
    java.io.IOException: Cannot run program "perl.exe": CreateProcess error=2, The system cannot find the file specified
    at java.lang.ProcessBuilder.start(Unknown Source)
    at java.lang.Runtime.exec(Unknown Source)
    at java.lang.Runtime.exec(Unknown Source)
    at java.lang.Runtime.exec(Unknown Source)
    at com.nokia.carbide.cpp.internal.sdk.core.model.SDKManager.checkPerlInstallation(SDKManager.java:817)
    at com.nokia.carbide.cpp.internal.sdk.core.model.SDKManager.<init>(SDKManager.java:155)
    at com.nokia.carbide.cpp.sdk.core.SDKCorePlugin.getSDKManager(SDKCorePlugin.java:79)
    at com.nokia.carbide.cpp.internal.sdk.ui.NewPluginChecker.checkForNewlyInstalledPlugins(NewPluginChecker.java:41)
    at com.nokia.carbide.cpp.sdk.ui.SDKUIPlugin.start(SDKUIPlugin.java:61)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)
    at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:913)
    at org.eclipse.core.internal.plugins.PluginDescriptor.doPluginActivation(PluginDescriptor.java:360)
    at org.eclipse.core.internal.plugins.PluginDescriptor.getPlugin(PluginDescriptor.java:340)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.ui.internal.EarlyStartupRunnable.getPluginForCompatibility(EarlyStartupRunnable.java:149)
    at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:73)
    at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
    at org.eclipse.ui.internal.Workbench$58.run(Workbench.java:2398)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
    Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
    at java.lang.ProcessImpl.create(Native Method)
    at java.lang.ProcessImpl.<init>(Unknown Source)
    at java.lang.ProcessImpl.start(Unknown Source)
    ... 27 more

    I think that was easy enough with changing the "start.bat" PATH setting
    from
    set PATH=C:\Qt\2010.04\mingw\bin
    set PATH=%PATH%;%SystemRoot%\System32
    to
    set PATH=%PATH%;%SystemRoot%\System32;C:\Qt\2010.04\mingw\bin
    I don't know if this Perl issue needs to be posted under a different thread.

    Nathan

Similar Threads

  1. eclipse symbian sdk integration
    By javantiger in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2009-01-28, 15:11
  2. Carbide 1.5 Eclipse 3.1.2 integration failure
    By rakete in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2007-04-10, 10:40
  3. Eclipse Carbide.j Integration Problem
    By saleem145 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-10-04, 01:54
  4. Eclipse and SDK 4.0 integration
    By mshouab in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2006-07-13, 17:57
  5. Nokia_3300_SDK and ints integration with Eclipse
    By AppliedMathematician in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-04-15, 20:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×