×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Dec 2009
    Posts
    71

    [Moved] Deploy on device problem

    Hi,

    Here is my problem, I need to use "QHttp" in my application.
    Deploying it on the simulator, everything works fine
    but when I deploy on device I get this error :

    - QHttp no such file or directory.

    I search the forum to find an answer but everything I try not work.

    I try to put :
    symbian {
    ...
    TARGET.CAPABILITY = NetworkServices
    ...
    }
    or put the keyword "network" or "NetworkService" at the first line -> Qt += core gui network

    I use Qt 4.7.0 and QtCreator.

    Maybe someone already have this problem here ?

    Thanks for answer.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,347

    Re: [Moved] Deploy on device problem

    Moving your thread in the Qt for Symbian section where you would get help from your peers.
    Nokia Developer Wiki Moderation team

  3. #3
    Regular Contributor
    Join Date
    Dec 2009
    Posts
    71

    Deploy on device problem

    Hi,

    Here is my problem, I need to use "QHttp" in my application.
    Deploying it on the simulator, everything works fine
    but when I deploy on device I get this error :

    - QHttp no such file or directory.

    I search the forum to find an answer but everything I try not work.

    I try to put :
    symbian {
    ...
    TARGET.CAPABILITY = NetworkServices
    ...
    }
    or put the keyword "network" or "NetworkService" at the first line -> Qt += core gui network

    I use Qt 4.7.0 and QtCreator.

    Maybe someone already have this problem here ?

    Thanks for answer.

  4. #4
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: [Moved] Deploy on device problem

    Do you get the error deploying or compiling? In any event, QHttp is deprecated, and you should be using the QtNetwork suite of classes.

  5. #5
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Deploy on device problem

    QHttp is deprecated. Use classes from the QtNetwork module: http://doc.qt.nokia.com/4.6-snapshot/qtnetwork.html

  6. #6
    Regular Contributor
    Join Date
    Dec 2009
    Posts
    71

    Re: [Moved] Deploy on device problem

    Thanks for help, I will check that.

Similar Threads

  1. how to deploy application on real device?
    By akshay0912 in forum Mobile Java General
    Replies: 3
    Last Post: 2009-04-22, 07:30
  2. [moved] On Device Debugging problem
    By slayv in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2009-03-20, 14:33
  3. [moved] The Problem With On Device Result???
    By xinliucun in forum Symbian User Interface
    Replies: 3
    Last Post: 2009-02-16, 09:10
  4. [moved] On Device Debug Problem
    By gailu in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2009-02-13, 16:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×