×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2009
    Location
    Greece
    Posts
    191

    Qt Creator 2.0 project settings problem

    I use Qt Creator 2.0.

    When I import any Qt program, lets say the animatedtiles example and select "Qt Simulator", if I try to run it i get

    "The process could not be started!"

    So I searched it here at the discussion boards and figured out that the path of the executable file is wrong.

    The problem is:

    In the build settings for "Qt Simulator", using Qt version Visual Studio 2008 (doesn't matter the version though) the build directory is "C:\NokiaQtSDK\Examples\4.6\animation\animatedtiles-build-simulator".
    When you press "Build", regardless if it is "Debug" or "Release" it creates these 2 folders in that directory.

    The thing is that if you press "Run" it will try to run the executable not in the corresponding debug/release folder but in the root folder C:\NokiaQtSDK\Examples\4.6\animation\animatedtiles-build-simulator which produces the following 2 lines in the output:

    Starting C:\NokiaQtSDK\Examples\4.6\animation\animatedtiles-build-simulator\animatedtiles.exe...
    The process could not be started!


    I tried to fix it by changing the working directory in the "Projects->Run Settings" but nothing happens.

    Is it a bug of the Qt Creator?
    Is there a way to fix this?

  2. #2
    Registered User
    Join Date
    Mar 2009
    Posts
    16

    Re: Qt Creator 2.0 project settings problem

    It looks like you may have found an issue in Qt Creator. Please report this as a bug againt Qt Creator at the Qt Bug tracker.

    Once opened, please post the issue number here so other people with the same problem can track it. Thank you.

  3. #3
    Registered User
    Join Date
    May 2009
    Location
    Greece
    Posts
    191

    Re: Qt Creator 2.0 project settings problem

    Just reported it to the Bug tracker: http://bugreports.qt.nokia.com/browse/QTCREATORBUG-1766

  4. #4
    Registered User
    Join Date
    May 2009
    Location
    Greece
    Posts
    191

    Re: Qt Creator 2.0 project settings problem

    Problem solved.

    There was a thing in the environment variables.
    Anyone interested take a look here:

    http://bugreports.qt.nokia.com/brows...#action_120005


Similar Threads

  1. Problem in Qt Creator
    By NMMA in forum Qt
    Replies: 3
    Last Post: 2010-06-15, 18:27
  2. QT Nokia sdk installation and QT Creator config problem
    By kapiluiet in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-06-02, 13:49
  3. Subfolders in my project in Qt Creator?
    By stegemann in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-05-25, 07:09
  4. Adding include paths to QT Creator project
    By guido666 in forum [Archived] Qt SDKs and Tools
    Replies: 5
    Last Post: 2009-10-05, 19:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×