×

Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    1

    Qt Creator 2.0 Run Settings: wrong executable

    Qt Creator 2.0 is coming up with the wrong executable in a QMake project with subdirs. The top-level project file (neurolab_all.pro):

    TEMPLATE = subdirs
    SUBDIRS = griditems neurolab neurogui neurolib automata thirdparty

    All the sub-projects are library projects except for neurolab, whose project file is:

    QT += gui

    TARGET = neurolab
    TEMPLATE = app

    SOURCES += main.cpp

    release { BUILDDIR=release }
    debug { BUILDDIR=debug }

    DESTDIR = $$OUT_PWD/../$$BUILDDIR
    TEMPDIR = $$OUT_PWD/$$BUILDDIR

    OBJECTS_DIR = $$TEMPDIR
    MOC_DIR = $$TEMPDIR
    UI_DIR = $$TEMPDIR
    RCC_DIR = $$TEMPDIR

    In the Run Settings for the project, Qt Creator tries to have

    neurolab_all-build-desktop/neurolab/debug/neurolab.exe

    for the executable, instead of the correct

    neurolab_all-build-desktop/debug/neurolab.exe

    Due to the utterly brain-dead decision for Qt Creator to put absolute path names in the .pro.user files, I cannot put the .user files in source control. I want a system that works upon checking out the code without a lot of fiddling.

    Qt itself is a great product, which I have been using with great success for over 10 years. Qt Creator, on the other hand, is getting more annoying and less functional with each release.

  2. #2
    Registered User
    Join Date
    May 2009
    Location
    Greece
    Posts
    191

    Re: Qt Creator 2.0 Run Settings: wrong executable

    I have the exact same problem so I am unable to use Qt Creator.

    (Posted afew days ago here: http://discussion.forum.nokia.com/fo...ttings-problem)

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    16

    Re: Qt Creator 2.0 Run Settings: wrong executable

    Try with the following pro file:

    Code:
     
    QT += gui
    
    TARGET = neurolab
    TEMPLATE = app
    
    SOURCES += main.cpp
    Don't try to do more. Qt Creator automatically does shadow builds in 2.0, which is why it probably breaks for you. Leave it to Creators build configurations to do the right thing.

    Also stuff like

    release { BUILDDIR=release }
    debug { BUILDDIR=debug }
    is simply wrong. The proper way is to do this:

    Code:
    CONFIG( debug, debug|release ) {
        # debug
    } else {
        # release
    }
    But before messing with this, try the basic example first

Similar Threads

  1. Qt Creator code completion not working with Qt Mobility for Symbian
    By ceefour in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2011-09-10, 05:02
  2. Qt Creator 2.0 project settings problem
    By favoritas37 in forum [Archived] Qt SDKs and Tools
    Replies: 3
    Last Post: 2010-06-29, 14:52
  3. QT Nokia sdk installation and QT Creator config problem
    By kapiluiet in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-06-02, 13:49
  4. S60_5th_Edition_SDK_v1_0 + Qt creator 2.0 + qt-symbian-opensource-4.7.0-beta1配置问题?
    By fish_of_deadsea in forum [Archived] Qt General ( Qt技术)
    Replies: 0
    Last Post: 2010-05-30, 06:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×