×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    3

    Unhappy CAknItemFinder link error, which dll do I need?

    In my project I need to highlight the phonenumber, mailbox address and URL in RichTextEditor. So I plan to us CAknItemFinder. I downloaded the "S60_3rd_SDK_MR_API_Plug-In_Pack_v5_43" and My working on SDK is "S60_3rd_Edition_SDK_Feature_Pack_2_v1_1_en". However, I would face the link error, such as "Undefined symbol: 'class CAknItemFinder * CAknItemFinder::NewL(int) (?NewL@CAknItemFinder@@SAPAV1@H@Z)'". I also dowloaded the sample "UseItemFinder" and it also would popped up such error.
    In AknItemFinder.h, it shows "Interface : CommonUI.dll". But the dll and lib already in the corresponding release folder.
    who can help me? Thanks a lot! which dll/lib do i need?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: CAknItemFinder link error, which dll do I need?

    They often work, but generally the plug-in packs are not compatible with SDK-s and devices with different platform releases.
    Decide what device(s) you want to support, and use the appropriate SDK plus the plug-in pack for that particular SDK.
    In short: whatever the page http://wiki.forum.nokia.com/index.php/Item_Finder_API says, the change also appears in the S60 3rd FP2 plug-in pack, there is no aknitemfinder.h+CAknItemFinder, but there is itemfinder.h containing CItemFinder

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    3

    Re: CAknItemFinder link error, which dll do I need?

    But in the page http://wiki.forum.nokia.com/index.php/Item_Finder_API, it said "series 60 5th edition extensions plug-in, the API is changed to CItemFinder and the same can be located at epoc32\include\itemfinder.h ". How can I get such API? Does this one can be worked well on My SDK.(S60_3rd_Edition_SDK_Feature_Pack_2_v1_1_en)

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: CAknItemFinder link error, which dll do I need?

    If you find it challenging to click on the blue "SDK API Plug-in" link in that article, and scroll a bit down for the link to the S60 3rd FP2 Plug-in pack, I can not help. It contains itemfinder.h.

Similar Threads

  1. [Help] Very weird DLL link error
    By sceleton in forum Symbian
    Replies: 0
    Last Post: 2007-05-11, 10:40
  2. can't link a dll
    By flyingdonkey in forum Symbian
    Replies: 2
    Last Post: 2007-04-03, 04:38
  3. Link with dll
    By vishwas_vincy11 in forum Symbian
    Replies: 3
    Last Post: 2006-10-10, 07:39
  4. Problem about dll link error!! help
    By mobilepig in forum Symbian
    Replies: 5
    Last Post: 2006-08-10, 07:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×