×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    not able to hear ring tone

    hi all,
    I have used the following link :
    http://www.newlc.com/en/Playing-a-WAV-file.html
    to play wav file but i am not able to listen any sound ,not on emulator and device also.

    what should be the issue?


    thanks,
    rohit negi

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: not able to hear ring tone

    That article is probably still valid, just you need to use epoc32\winscw for storing the audio file in current SDK-s.
    You can find some really compressed example in #3 of http://discussion.forum.nokia.com/fo...-for-an-newbie

  3. #3
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    I used PlayUtility.h and PlayUtility.cpp in the following link:
    http://wiki.forum.nokia.com/index.ph...ng_audio_files
    but still i am not able to listen the wav file in the emulator ,i am using s60_3rd_fp2 ,and in case of device it gives the error:
    unable to install as i deploy the wav file in .pkg file ,i have tested it in E72 device.

  4. #4
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    Following is my code please check it , code is giving Panic MMFAudioClient 2 at iPrepared = ETrue; line

    //abdcontainerview.cpp
    TBool CabcContainerView::HandleSelectMenuItemSelectedL( TInt aCommand )
    {
    // TODO: implement selected event handler

    CSoundPlayer *pl = CSoundPlayer::NewL(_L("C:\\S60\\devices\\S60_3rd_FP2_SDK_v1.1\\epoc32\\winscw\\c\\system\\Apps\\ring.wav"));
    pl->MapcInitComplete(0,TTimeIntervalMicroSeconds());
    pl->Play();
    return ETrue;
    }

    //in soundplayer.cpp
    void CSoundPlayer::MapcInitComplete(TInt aError, const TTimeIntervalMicroSeconds& /*aDuration*/)
    {
    if(aError == KErrNone)
    {
    iPrepared = ETrue; // at this point Panic MMFAudioClient 2
    iMdaPlayer->SetVolume(iMdaPlayer->MaxVolume());
    iMdaPlayer->Play();
    }
    }


    please give any solution

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: not able to hear ring tone

    Quote Originally Posted by rohitnegi View Post
    Following is my code please check it , code is giving Panic MMFAudioClient 2 at iPrepared = ETrue; line
    It can not reach that line, since your path is wrong.
    CSoundPlayer *pl = CSoundPlayer::NewL(_L("C:\\S60\\devices\\S60_3rd_FP2_SDK_v1.1\\epoc32\\winscw\\c\\system\\Apps\\ring.wav"));
    The c: drive of the emulator is C:\S60\\devices\S60_3rd_FP2_SDK_v1.1\epoc32\winscw\c, so your path should be _L("c:\\system\\Apps\\ring.wav").

  6. #6
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    i have changed the path as said by you but i am getting errror:Panic MMFAudioClient 2 at the point which is specified in prevous post.

  7. #7
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    i have done it after commenting the pl->MapcInitComplete(0,TTimeIntervalMicroSeconds()); line
    but it is not ringing at device E72 while i have deployed it as follows:
    "$(EPOCROOT)epoc32\data\z\resource\apps\sound\ring.wav" -"!:\resource\apps\sound\ring.wav"

    what can be the problem?
    Last edited by rohitnegi; 2010-07-05 at 06:43.

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: not able to hear ring tone

    Quote Originally Posted by rohitnegi View Post
    i have done it after commenting the pl->MapcInitComplete(0,TTimeIntervalMicroSeconds()); line
    That is a good idea, I have not noticed that line
    but it is not ringing at device E72 while i have deployed it as follows:
    "$(EPOCROOT)epoc32\data\z\resource\apps\sound\ring.wav" -"!:\resource\apps\sound\ring.wav"

    what can be the problem?
    Two things:
    - !:\ is the user-selectable drive (when the installer asks "Phone memory or Memory card" - as a quick workaround use c:\
    - \resource\apps\sound and \system\apps are two different locations

  9. #9
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    it is stored in phone memory .I have used both the path but still having the same problem.
    "$(EPOCROOT)epoc32\data\z\resource\apps\ring.wav" -"!:\resource\apps\ring.wav" and
    "$(EPOCROOT)epoc32\data\z\resource\apps\sound\ring.wav" -"!:\resource\apps\sound\ring.wav"
    and i also tried to give it in c:\ but then it gives error :
    can not find ...

  10. #10
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    Is it the problem of device or i would have to make changes somewhere else like mmp file.?

  11. #11
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: not able to hear ring tone

    The format is "source file on your PC"-"target file on your phone"
    $(EPOCROOT) is simply extracted to c:\Symbian\9.2\S60_3rd_FP1\, or whatever SDK you use. Modify your changes according to this revelation.

  12. #12
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    Still have the same problem . what should i do now?

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,684

    Re: not able to hear ring tone

    What do you install now, and where?

  14. #14
    Regular Contributor
    Join Date
    Jan 2010
    Posts
    82

    Re: not able to hear ring tone

    I have installed application on device E72 after changing the path of .wav file in the .pkg file manytimes but still no sound .
    will the .wav file be installed on the device also ?

  15. #15
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: not able to hear ring tone

    Try the following in your .pkg file:
    Code:
    "$(EPOCROOT)epoc32\data\z\resource\apps\sound\ring.wav" -"c:\data\ring.wav"
    And use the following path in your code:
    Code:
    CSoundPlayer *pl = CSoundPlayer::NewL(_L("C:\\data\\ring.wav"));
    Nokia Developer Wiki Moderation team

Similar Threads

  1. Replies: 2
    Last Post: 2009-12-24, 10:33
  2. Ring Tone
    By rokroff in forum Symbian
    Replies: 1
    Last Post: 2009-02-24, 10:25
  3. Dial Tone and Ring Tone
    By Aliencse in forum Symbian Media (Closed)
    Replies: 5
    Last Post: 2008-08-06, 10:35
  4. ring tone ripping
    By bmorezcmunee in forum General Development Questions
    Replies: 0
    Last Post: 2004-12-03, 19:03
  5. ring tone
    By cr3ature in forum Digital Rights Management & Content Downloading
    Replies: 0
    Last Post: 2002-10-28, 23:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×