×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    20

    Smile what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    Hi,
    I've built and deployed a java ME gps based app using the S60 3rd Edition FP1 sdk for midp emulator....the app uses the location api but nothing exceptional other than that...

    i've deployed the app to a nokia 5230 device, which has s60 version 5.0 , java build version 1.4..43 cldc 1.1, midp 2.0

    is there somewhere i can find what other models the app should work on?
    for example should it work on all s60 devices with gps capabilities?
    i want to test on a new device and i dont want to end up buying an incompatible one...thanks!!!!

    ps...completely different question, but is there someway to set up automatic alerts to my email account when i get responses to a thread? ,,,thanks again

  2. #2
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    You can find specifications of Nokia devices here. The list can be filtered to show, for example, only S60-5th devices.

    Also, look at the Java Verified device matrix, which also provides some information about compatibility.

    To change your email options, click on "general settings" in the left-hand column of this page.

    Graham.

  3. #3
    Registered User
    Join Date
    Feb 2010
    Posts
    20

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    thanks Graham,,,,

  4. #4
    Registered User
    Join Date
    Feb 2010
    Posts
    20

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    Hi Graham,
    thanks for the information,,,looking at the Java Verified Device Matrix, would it be very naive of me to expect that my application should run on all manufacturer devices that have the relevant JSRs ? I'm thinking that java is in theory a "write once run anywhere" language?

  5. #5
    Registered User
    Join Date
    Oct 2009
    Location
    Noida
    Posts
    941

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    Roryo - You can click on this link http://www.forum.nokia.com/Devices/D...rix_gps_1.html
    It gives you a list of devices from Nokia that supports GPS, so on all the S40 & S60 devices listed on this page will support your application except N900 - the Maemo device also listed on this link.


    looking at the Java Verified Device Matrix, would it be very naive of me to expect that my application should run on all manufacturer devices that have the relevant JSRs ? I'm thinking that java is in theory a "write once run anywhere" language?
    Yes, if you get any Java device which has MIDP 2.0 / CLDC 1.1 and JSR 179 /w inbuit GPS - your application will run on it, thou it might need some porting efforts to match the UI screen resolution and keyboard or touch screen of the target device.
    Thanks,
    Ekta

  6. #6
    Registered User
    Join Date
    Feb 2010
    Posts
    20

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    thanks for that Exta, Rory

  7. #7
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    Many other issues can prevent a device from running your application, such as memory, screen size, processor performance, file storage, security policy, and API implementation.

    In terms of buying another phone for testing, you need to think about what devices you want to run your application, and be prepared to spend some days debugging.

    Some advice for developing for multiple devices can be found in the wiki.

    Graham.

  8. #8
    Registered User
    Join Date
    Feb 2010
    Posts
    20

    Re: what nokia models will my s60 midp 2.0, cldc 1.1 app work with?

    thanks for the wiki link Graham, useful article...

Similar Threads

  1. Setting WallPaper/Ringtone via J2ME(CLDC/MIDP) app
    By gaurav_vohra in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2011-05-06, 19:53
  2. NOkia s60 2nd edition chinese SDK with mimer database. CLDC 1.0 MIDP 2.0.
    By 86.coolguy@gmail.com in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2010-03-01, 05:59
  3. Replies: 5
    Last Post: 2007-09-10, 16:25
  4. How to make a midlet work on MIDP 1.0 and CLDC 1.0 with the NokiaUI?
    By MobileVisuals in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2007-06-16, 17:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×