×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Apr 2010
    Location
    Serbia
    Posts
    12

    Question s60 3rd, 5th edition compatibility?

    Hi, I'm developing a nice little widget and I was wondering how can I test it for 3rd edition s60. I have developed it for 5th edition and I'm not sure if it'll work on 3rd edition devices. What's the difference between 3rd and 5th edition s60 and how can I test my widget without actually having to have all the necessary devices?

    By the way, as far as I know, WRT works on Maemo and MeeGo platforms so how can I test my widget for compatibility with those platforms.

    Thanks.

  2. #2
    Nokia Developer Champion
    Join Date
    Nov 2007
    Location
    Rome, Italy
    Posts
    2,406

    Re: s60 3rd, 5th edition compatibility?

    Hi aiveldesign,

    Remote Device Access allows you to perform remote tests on real devices:

    http://www.forum.nokia.com/Devices/R...device_access/

    Hope it helps,
    Pit

  3. #3
    Registered User
    Join Date
    Apr 2010
    Location
    Serbia
    Posts
    12

    Re: s60 3rd, 5th edition compatibility?

    Yes I know about that but my widget communicates with a custom made HTTP server on my computer so it's required that the device is connected to my wireless network. I don't think this simulators would do the job. That's why I asked for some kind of documentation that can explain the WRT compatibility for all Nokia platforms.

    I'm basically using jQuery with AJAX and JSONP to communicate with the server, some sensor data (if there is a sensor), display rotation (widget can only run in landscape mode) and nothing else. I guess that should work on all platforms right? I don't use any other specific API or anything, so I guess it should work fine. Am I right?

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: s60 3rd, 5th edition compatibility?

    basically platform services (like sensors) are only available on 5th ed devices, and the WRT Widgets are not supported with 3rd MR devices, some 3rd FP1 devices would also require specific firmware in order to support WRT widgets. Basically best would be if you could test them with real devices, so might be good idea to check second hand market for some cheap testing devices.

  5. #5
    Registered User
    Join Date
    Jun 2011
    Posts
    5

    Re: s60 3rd, 5th edition compatibility?

    Quote Originally Posted by aiveldesign View Post
    What's the difference between 3rd and 5th edition s60?
    See "binary compatibility report between S60 3rd Edition and S60 5th Edition on ARM".

    See also Nokia Developer's Library > S60 5th Edition C++ Developer's Library v2.1 > Designing applications for S60 5th Edition > Porting applications to S60 5th Edition > Binary compatibility.

  6. #6
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: s60 3rd, 5th edition compatibility?

    Quote Originally Posted by aiveldesign View Post
    Hi, I'm developing a nice little widget and I was wondering how can I test it for 3rd edition s60. I have developed it for 5th edition and I'm not sure if it'll work on 3rd edition devices. What's the difference between 3rd and 5th edition s60 and how can I test my widget without actually having to have all the necessary devices?

    By the way, as far as I know, WRT works on Maemo and MeeGo platforms so how can I test my widget for compatibility with those platforms.

    Thanks.
    Please read trough this site.
    http://www.developer.nokia.com/Resou...e-support.html

    Key differences between 3rd edition fp2 and 5th edition is of course screen size and interaction style. 3rd edition devices are controlled with keypad where as 5th edition devices are touch devices. I would say that this is a big enough gap to justify for creating different versions of widget for lower resolution non-touch devices (3rd ed.) and touch devices (5th and Symbian^3). In addition many of 5th edition devices have received latest browser where as older 3rd edition devices are still using an older one.

    WRT is Symbian specific platform, so you really don't have to worry about Maemo/MeeGo. There was a Qt Web Runtime project for N900, but it was ramped down earlier this year.

    Br,
    Ilkka

Similar Threads

  1. S60 3rd Edition Application Compatibility
    By Lannie_0327 in forum Symbian
    Replies: 4
    Last Post: 2010-07-01, 14:18
  2. 3rd and 5th edition compatibility
    By dmunsie in forum Symbian User Interface
    Replies: 11
    Last Post: 2009-12-07, 13:16
  3. Platform compatibility for S60 5th Edition
    By ltomuta in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 0
    Last Post: 2009-10-11, 20:00
  4. [moved] S60 5th Edition compatibility query
    By nisheethpandey in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2009-03-25, 06:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×