×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Sep 2009
    Posts
    9

    Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    Have developed flash lite application, that get photo from camera and upload it to server involving APIBridge. *.swf file work fine if it is located c:/Other/Trusted. But it does not work if *.swf file is located in some other places. The problem is with uploading picture or video file from phone to the server. This problem exists for different models of phones (tested on 5800 (v50.0.005) and 5530 v10.0.050). Note that one can get foto or video since API bridge in this case works fine.
    When one install application via widget (in our case packed *.swf inside html) there is no this problem for a few first uploads if the applicaton was not installed before. After that problrm arises and even master reset can not cancel it. The problem is marked by 404 error.
    Seems that there is some security feature which block this uploading
    Because at the point of uploading there is no request from phone to the server, but requests from flash lite application to server work fine.

  2. #2
    Registered User
    Join Date
    Sep 2009
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    Looks like problem is with phone localization. When I set English language, uploading work fine. But not work, when some other language is set. Local file path, that API Bridge return to flesh in this case is not right. For exemple: When I set Russian language, API Bridge return path to file 'Images/Камера/201007/201007A0/0807201005.jpg' , but real path is 'Images/Camera/201007/201007A0/0807201005.jpg'. With Javascript API Bridge work correct with any language.

  3. #3
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    I think you already found the solution . You can do three more steps :
    1- Report it as bug at Report a Bug @ Forum Nokia and lets see if they are able to reproduce it.
    2- If u have good knowledge of Symbian C++, create one of ur own upload plugin .
    3- You can go for alternatives like Kuneri Lite Upload Plugin but it costs u on using their plugins.

    Best Regards,
    SajiSoft

  4. #4
    Registered User
    Join Date
    Sep 2009
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    Yes Thanks. I will report.

  5. #5
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    Hi,I want to develop a similar application:get photo from camera and upload it to the server involving APIBridge.But it does not work,it displayed the errors:Unable to find file 'E:/apiexample/Undefined'

  6. #6
    Registered User
    Join Date
    Sep 2009
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    Need more info. What Web technology are you use with API Bridge? Also check from wheare API Bridge get this path "E:/apiexample/Undefined"

  7. #7
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    I use flash lite with apibridge. All sample files are in the "E:/apiexample"folder of my phone.(C:is the phone memory,E is the memory card)

  8. #8
    Registered User
    Join Date
    Sep 2009
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    So, you need check what value set for
    Code:
    inParams.FileName
    that used in function
    Code:
    bridge.UploadFile(inParams,onFileUpload);

  9. #9
    Registered User
    Join Date
    Jun 2010
    Posts
    9

    Re: Wrt + Flash Lite + API Bridge does not work fine for upload file on 5800 and 5530

    thanks for your reply. I have solved my problems though I didn't know the real reason. I updates my 5800w to the newer version then the apibridge runs normally.

Similar Threads

  1. Replies: 3
    Last Post: 2010-05-22, 17:45
  2. flash lite api bridge - thumbnails
    By kinski76 in forum [Archived] Flash Lite on Nokia Devices
    Replies: 15
    Last Post: 2010-03-31, 15:38
  3. Flash lite api bridge - capture image problem
    By kinski76 in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2010-02-22, 21:47
  4. Nokia API Bridge for Flash Lite compatible devices
    By stephenedgar in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2009-12-18, 17:25
  5. 5800 XM + Flash Lite 3.1 + Sensor API = wild data ??
    By sixtuslab in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2009-09-19, 21:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×