×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,672

    On-line library issues

    Try #3 first.

    #1 Symbian^3 API documentations are useless in the on-line library. Search for any well known Symbian C++ class, like RFs, CCoeControl, or less known, like TCourse, and click on the very first hit (the one without any comment - second, third hits usually have some addition "in Base E32", or something similar). The introductory bla-bla is probably there, but after that the rest of the page is an empty dump. First a short dump (single class member per line, doxygen-style "contents page"), then the detailed description comes, just the details are missing.

    #2 Why is it the first one in the list of hits?

    #3 Links work strange. Here is the link for CCoeControl http://library.forum.nokia.com/index...6EBE8C160.html click on it. Two things can happen:
    - if you have used the library recently, the page for CCoeControl opens
    - if you have not used the library, there will be a noticeable hesitation, and the library main page opens. In this case if you simply close it (assuming multiple tabs, so the browser itself is not closed), and try again, the referred page will appear.
    At least with IE8, Chrome and Opera.

  2. #2
    Registered User
    Join Date
    May 2007
    Location
    USA
    Posts
    120

    Re: On-line library issues

    Hi wizard_hu,

    I download the libraries to my PC for offline reading, so it's safe to say that I haven't used the libraries online recently. I tried #3 as you suggested and it took me to the page for CCoeControl correctly. I also tried a search or two from the library (not just the S^3 library) and the results seem to be OK, but I performed only limited tests and all on IE8 under Vista 64.

    However, I did find one bug:

    In the online library, next to the search box, click on "Search scope:" link. This opens a second window where you can choose the entire library, or a subset. Select "Search only the following topics:" and then "New..." to define a set of topics which opens yet another window. In that window observe that the OK button is not enabled. Ostensibly choosing a topic should enable it. However that doesn't actually happen...I selected one, two, ... all topics and was never able to click OK. Only Cancel works.

    Anyone confirm this using a different browser? On this machine I have only IE8.
    --Himanshu
    Nokia N8-00 (Symbian Belle, NAM RM-596)
    Nokia 5800 XpressMusic (S60 5th Ed., NAM RM-428, v51.2.007)
    S/w: ADT v1.4 + S60 5.0 SDK on Win7 x64

Similar Threads

  1. Replies: 5
    Last Post: 2008-09-23, 09:39
  2. Replies: 7
    Last Post: 2007-05-14, 14:04
  3. e32def.h in C library project and carbide express vs sdk command line tools
    By baumannpan in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2007-04-03, 10:33
  4. Replies: 1
    Last Post: 2006-10-21, 05:32
  5. How to hide a vertical line in Single-line listbox!
    By ctpthanh in forum Symbian User Interface
    Replies: 2
    Last Post: 2005-04-09, 08:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×