×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Cannot make QtMobility TP2

    Hi

    I have downloaded TP2 source from http://qt.gitorious.org/qt-mobility/...ball/1.0.0-tp2.

    Unpacked the files to C:\QtMobility\TP2.

    Then succesfully ran configure.

    When i then try to make, I get the following error:

    Code:
    bldmake bldfiles
    process_begin: CreateProcess((null), bldmake bldfiles, ...) failed.
    make (e=2): The system cannot find the file specified.
    make: *** [ABLD.BAT] Error 2
    I'm obviously missing somthing out here, does anyone have any idea to what it might be?

    Im all new to mobile development on Symbian, and my goal with TP2 is to play with the QCamera class and relatives. As far as I can figure out I need either 1.0.0-beta or 1.0.0 TP's.

    I hope somebody out there can help me figure this out.

    Best regards
    /Anders

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Cannot make QtMobility TP2

    There are 1.0.0 and even 1.1.0, why do you want to use 1.0.0-beta or 1.0.0 TP2?

  3. #3
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    I am looking to use the camera functions in QCamera in the multimedia API.

    Is I have understood, the QCamera didn't make it in 1.0.0 or 1.0.1 - isn't that right?

    I have tried grapping 1.1.0 from GIT as well, and it gives the exact same error when making it.

    I have no reason to make the files my self. Any precompiled package for symbian would be fine for me.

    So if you can point me in the right direction on how to get a hold on the camera functions in 1.1.0, I would be a very happy man.. :-)

    /Anders

  4. #4
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Cannot make QtMobility TP2

    I can only guess your are trying to build Qt Mobility for Symbian?

  5. #5
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    Correct, I havent found any other way to utilize the Camera API.

  6. #6
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    18

    Re: Cannot make QtMobility TP2

    You need ot build Q Mobiliy like his:
    make release-gcce
    or make debug-gcce or make winscw
    Code Monkey, QtMobility, Nokia

  7. #7
    Nokia Developer Expert
    Join Date
    Dec 2009
    Posts
    81

    Re: Cannot make QtMobility TP2

    Isn't 1.0.0-tp2 the 2nd tech preview for the 1.0.0 release?

    Have you tried the master branch of Qt Mobility?

  8. #8
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    Same error building make release-gcce.

    During the weekend i came to think that the problem might relates to something outsite Qt.

    The error I get from make, might indicate that make can't start the process "bldmake", but I can't seem to figure out what the missing piece is.

    So it might be some other component I need to have set up before I am able to go further.

    /Anders

  9. #9
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    I have installed 1.0.1 of the Nokia Qt SDK which includes the main stuff.

    Skip the TP parts, and focus on trying to build the 1.1.0 branch. It seems to contain camera api as well.

    I'm not necessarily interested in building the software myself, it just seems to be the only way I can build against a Qt library with the Camera API present.

    /Anders

  10. #10
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    Hi

    Please consider this thread closed.

    It seemed my problem was that I was missing a lot of Symbian specific API's on my machine.

    So for now I don't really need to build my own version of QtMobility - that what's just me as a newbie mixing up the different parts of building.

    /Anders

  11. #11
    Regular Contributor
    Join Date
    May 2007
    Posts
    468

    Re: Cannot make QtMobility TP2

    Regarding the original issue i.e need of Camera it should be available in the next release within few weeks.

    Cheers,
    Jack

  12. #12
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    Hi Jack

    That sounds terrific.

    Looking forward to it.

    /Anders

  13. #13
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    66

    Re: Cannot make QtMobility TP2

    For future reference, if other experiences this.

    I have now managed to build a TP of 1.1.

    If i just use the Qt Prompt (e.g. started from C:\nokiaqtsdk\symbian\SDK\bin\qtenv2.bat) then all works fine.

    /Anders

Similar Threads

  1. Replies: 4
    Last Post: 2010-11-27, 18:33
  2. Replies: 3
    Last Post: 2010-08-17, 08:51
  3. Error with QtMobility 1.0 after succesfully intall QtMobility tp2
    By Estel in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-06-21, 21:21
  4. QtMobility
    By prathibha83 in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2010-05-07, 15:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×