×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    1

    SDKMaintenanceTool just hosed my install

    I just installed a brand new instance of the nokia Qt SDK, It wouldn't let me compile as there was an update button in place of configuration manager. I went ahead and did the update (for Qt mobility (1.0.1 I presume), smartinstaller, and Qt4.6.3-2). The SDKMaintenance tool hosed my install.

    My nokiaQtSDK dir now contains 3 dirs (Maemo, QtCreator, Symbian) most of which are empty and the total size of nokiaQtSDK is 22MB.

    Really nokia, you not only don't know how to make a decent phone, but your suggested development environement really sucks (I love Qt for desktop, hate for symbian). So now that my app is done, and getting ready to deploy.... I get to go code it in j2me so that it will work, be easily deployed, and I don't get the headache of SDK issues (of which my old setup still compiles without warnings, the nokiaQtSDK compiles with 500 warnings and that number changes every compile even when I dont make any changes to code whatsoever, sometimes it tells me I have 342 warnings the next it tells me I have 786 warnings....)

    Really nokia, If you want to survive, ditch maemo and run android. they are very similar, linux microkernal based open source operating systems. Android has a lot going for them - Most important to me, it was very easy to develop my app for android, getting it signed was free, and the development environment is solid (using plugins for eclipse....)

    Really I am going to take the weekend to decide if I even want to finish this project for nokia devices... I can make better use of my time writing new apps for android, instead of porting my apps to symbian/maemo.

    If I have to do an update to get new QtMobility lib, make sure the update doesn't destroy everything I had setup and working for a while.

    P.S. to uninstall you have to use the SDK Maintenance tool which I guess is broken on my machine... so I can't uninstall the SDK or install again over it... I guess I am stuck to virtual machine dev for the rest of my OS's life (which if you have to connect a phone via USB to VM it is a pain in the rear, and sometimes just doesn't work)

    Edit:: sorry, rough morning... So I deleted all the files manually and made sure everything was removed from my PATH. Reinstalled the NokiaQtSDK offline version, updated Qtmobility and smartinstaller, but not Qt 4.6.3-2 and I can compile (with 600 some warnings...)... The maintenance tool if you use it on a brand new install will break it though..
    Last edited by pleasuretek; 2010-07-11 at 01:30. Reason: can't even uninstall

  2. #2
    Registered User
    Join Date
    May 2009
    Location
    Paraguay - Ciudad del Este
    Posts
    40

    Angry Re: SDKMaintenanceTool just hosed my install

    I had the same problem today!.

    I had Nokia Qt SDK 1.0 (final) working fine on my machine, but when I wanted to use Qt Mobility.. the story begins.

    The first issue started when I try to do a "#include <QMediaPlayer>". Using Simulator the code was working fine, but when compiling the code for Symbian, Qt Mobility wasn't found on the SDK. (It supposed that Nokia Qt SDK 1.0 has Qt Mobility 1.0.1, right?). Ok, with a little research I found this http://bugreports.qt.nokia.com/browse/QTSDK-98. It's a bug with the SDK, something like "oh boy, we forgot to include Mobility for Symbian". In the Nokia Qt SDK bugtracker says that the bug was solved, and there's an update in the Nokia Qt SDK repo.

    I said "good!, a fast solution, now I can back to write code" (oh boy), so I upgraded the Nokia Qt SDK.. and I got the same result as this topic: the installation was totally hosed. So I had to download again the SDK (900MB) to make a full reinstall. Seriously guys, this is REALLY a bad shoot. Ok, there's certain kind of bug that every software has. But not including the Mobility in the SDK when you're promoting "bundled Qt Mobility"?. An upgrade tool that hosed the whole installation? A LOT of warnings when you build a Hello World app?

    So as @pleasuretek, I have to delete the Nokia Qt SDK folder, reinstall it again. Upgrade again to have Qt Mobility working (this time the upgrade tool doesn't hosed the installation)... but guess what?? Qt Mobility still doesn't work after the upgrade! Come on boys, seriously!

    Totally agree with pleasuretek !

    PD: Sorry for my English.
    Last edited by alexismedina; 2010-07-12 at 19:13. Reason: typo

  3. #3
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: SDKMaintenanceTool just hosed my install

    Quote Originally Posted by alexismedina View Post
    I had the same problem today!.


    So as @pleasuretek, I have to delete the Nokia Qt SDK folder, reinstall it again.

    Totally agree with pleasuretek !

    PD: Sorry for my English.
    Hi,
    Deleting the folders a total disaster for any application under Windows Vista and other OS.
    You should have gone into Control Panel -> Programs applications-> Nokia Qt SDK ->Uninstall applications.
    This would have run the application uninstall and cleaned up before install another copy.

    Please attempt to remove what is left by Control Panel -> Programs applications-> Nokia Qt SDK ->Uninstall applications.

    Your English is ok
    Thanks
    Jim
    Last edited by jimgilmour1; 2010-07-14 at 09:27.

Similar Threads

  1. N85: DLL install error: unable to install a protected application from an untrusted
    By Donald.Eaves in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2009-02-06, 22:34
  2. [split]Install sis on Series 40 (was. Re: install and run sis on s60 2nd edition fp3)
    By dariusmizuro in forum General Development Questions
    Replies: 1
    Last Post: 2009-01-15, 08:19
  3. Replies: 2
    Last Post: 2008-03-17, 12:56
  4. Replies: 0
    Last Post: 2008-02-14, 10:27
  5. Cant install NMIT - invalid response during install
    By dkguru in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2003-12-11, 13:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×