×

Discussion Board

Results 1 to 4 of 4

Thread: stdapis missing

  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    6

    stdapis missing

    I am trying to compile an application using Symbian SDK 3 (No FP). The project includes some files from EPOC32\include\stdapis. The stdapis include folder does not exist. I thought I needed to install Open C/C++ but installing it didn't add the stdapis folder.

    Where can I get stdapis from?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,734

    Re: stdapis missing

    It is unclear which SDK you mean:
    - S60 3rd? You should not use that
    - S60 3rd MR? (it is still no FP, just it has substantial improvements) I use this one, and the Open C/C++ installer adds stdapis folder
    - Symbian^3 SDK? It contains stdapis folder by default.

  3. #3
    Registered User
    Join Date
    Jul 2010
    Posts
    6

    Re: stdapis missing

    I am using S60 3rd edtion. Could you please tell me why I shouldn't use that?

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,734

    Re: stdapis missing

    If you are using Vista / Windows 7, make sure that you install the Open C/C++ plugin with right-click+Run as Administrator

    Otherwise S60 3rd edition SDK is a bit unstable, I do not know the exact details, but it has problems with building many types of codes - some parts are missing from it, though there may be some extras too (probably that is why it is still available). It may have integration issues too, that can be a reason if the Open C/C++ plugin can not handle it correctly.
    However when discussing about S60 3rd edition noFP SDK-s, we usually assume S60 3rd MR (Maintenance Release, so it is still noFP, just with improvements in the SDK itself). And on S60 3rd MR, Open C/C++ installs without any problem.

Similar Threads

  1. Difference betweeb libc and stdapis
    By smartmobili in forum Symbian
    Replies: 1
    Last Post: 2009-06-18, 11:54
  2. Please Help, What am I missing ?!?
    By Dvirus in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2009-04-21, 10:28
  3. What am I missing?
    By dj1970uk2 in forum Symbian
    Replies: 3
    Last Post: 2009-02-15, 18:06
  4. What am I missing?
    By mymira in forum Symbian
    Replies: 7
    Last Post: 2008-02-04, 09:24
  5. Missing file for KIS000607 is ... really missing !
    By cyke64 in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 4
    Last Post: 2007-04-16, 18:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×